Bug 257553 - dns/knot-resolver: upgrade to 5.4.0
Summary: dns/knot-resolver: upgrade to 5.4.0
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Li-Wen Hsu
URL: https://www.knot-resolver.cz/2021-07-...
Keywords:
: 256221 (view as bug list)
Depends on:
Blocks:
 
Reported: 2021-08-02 09:36 UTC by Leo Vandewoestijne
Modified: 2021-08-03 21:44 UTC (History)
3 users (show)

See Also:


Attachments
knot-resolver 5.4.0 (7.15 KB, patch)
2021-08-02 09:36 UTC, Leo Vandewoestijne
freebsd: maintainer-approval+
Details | Diff
knot-resolver 5.4.0 - spaces/tabs (6.21 KB, patch)
2021-08-03 08:25 UTC, Leo Vandewoestijne
freebsd: maintainer-approval+
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Leo Vandewoestijne 2021-08-02 09:36:24 UTC
Created attachment 226871 [details]
knot-resolver 5.4.0

Last week knot-resolver 5.4.0 was released. This patch updates the port accordingly.

Succesfully tested with portlint, portclippy, portfmt, poudriere.
Includes all of PR 256221.
Comment 1 Chris Hutchinson 2021-08-02 15:04:31 UTC
*** Bug 256221 has been marked as a duplicate of this bug. ***
Comment 2 Li-Wen Hsu freebsd_committer 2021-08-02 18:55:12 UTC
The patch is using space for indent, but the original files are using tab. This causes the patch is not easy to be applied. Is it possible for you to adjust your editor or VCS settings and submit a new patch? Thanks!
Comment 3 Leo Vandewoestijne 2021-08-03 08:25:54 UTC
Created attachment 226904 [details]
knot-resolver 5.4.0 - spaces/tabs
Comment 4 commit-hook freebsd_committer 2021-08-03 21:44:50 UTC
A commit in branch main references this bug:

URL: https://cgit.FreeBSD.org/ports/commit/?id=eef99349b29d7e8588ca7c109062ef79ef24dcbf

commit eef99349b29d7e8588ca7c109062ef79ef24dcbf
Author:     Leo Vandewoestijne <freebsd@dns.company>
AuthorDate: 2021-08-03 21:44:16 +0000
Commit:     Li-Wen Hsu <lwhsu@FreeBSD.org>
CommitDate: 2021-08-03 21:44:16 +0000

    dns/knot-resolver: Update to 5.4.0

    Changes: https://www.knot-resolver.cz/2021-07-29-knot-resolver-5.4.0.html

    PR:             257553

 dns/knot-resolver/Makefile             | 46 ++++++++++++++++++----------------
 dns/knot-resolver/distinfo             |  6 ++---
 dns/knot-resolver/files/krescachegc.in |  3 +--
 dns/knot-resolver/files/kresd.in       | 36 +++++++++++++++++++++++---
 dns/knot-resolver/pkg-plist            |  1 +
 5 files changed, 63 insertions(+), 29 deletions(-)