Bug 257619 - textproc/kibana7 (kibana7-7.13.4) does not start
Summary: textproc/kibana7 (kibana7-7.13.4) does not start
Status: In Progress
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Juraj Lutter
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-08-04 15:23 UTC by Andre Rikkert de Koe - ARK-ICT
Modified: 2021-08-30 23:08 UTC (History)
3 users (show)

See Also:
bugzilla: maintainer-feedback? (elastic)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Andre Rikkert de Koe - ARK-ICT 2021-08-04 15:23:57 UTC
root@monitor:/etc/rc.conf.d # pkg info | grep kibana
kibana7-7.13.4                 Browser based analytics and search interface to ElasticSearch
root@monitor:/etc/rc.conf.d # cat /etc/rc.conf.d/kibana 
kibana_enable="YES"
kibana_syslog_output_enable="YES"
root@monitor:/etc/rc.conf.d # service kibana start
Starting kibana.
root@monitor:/etc/rc.conf.d # date
Wed Aug  4 17:16:13 CEST 2021
root@monitor:/etc/rc.conf.d # grep kiba /var/log/messages | tail -1
Aug  4 17:16:11 monitor kibana[57516]: Kibana does not support the current Node.js version v14.17.0. Please use Node.js >= v14.17.2.
root@monitor:/etc/rc.conf.d # service kibana status
kibana is not running.
root@monitor:/etc/rc.conf.d #
root@monitor:/etc/rc.conf.d # pkg info | grep node | grep 14.17
node14-14.17.0                 V8 JavaScript for client and server
root@monitor:/etc/rc.conf.d
Comment 1 Juraj Lutter freebsd_committer 2021-08-05 08:36:05 UTC
Thank you for the report, this is not directly related to kibana, but more to www/node14 and www/npm-node14. Those two ports needs to be updated.

CC'ing bhughes@
Comment 2 Andre Rikkert de Koe - ARK-ICT 2021-08-05 10:33:34 UTC
(In reply to Juraj Lutter from comment #1)

Thanks for your answer.
The defined dependencies in the kibana7 port currently don't specify v14.17.2 :

root@monitor:~ # grep www/ /usr/ports/textproc/kibana7/Makefile | grep node
BUILD_DEPENDS=	node14>=14.17.0:www/node14 \
		npm-node14>0:www/npm-node14
RUN_DEPENDS=	node14>=14.17.0:www/node14
root@monitor:~ # 

So the port will install, though node 14.17.2 is needed.
Comment 3 Juraj Lutter freebsd_committer 2021-08-06 10:57:41 UTC
After update of www/kibana7 to 7.14.0, even node.je 14.17.3 is needed.

review D31433 has been opened for www/node14 maintainer.
Comment 4 ari 2021-08-12 11:55:32 UTC
Can this port be reverted to a working version? Really it should not be upgraded without a basic 'does it run' test.
Comment 5 Juraj Lutter freebsd_committer 2021-08-30 20:04:02 UTC
We are working hard to get the update to node17.14.5 committed.
Comment 6 ari 2021-08-30 23:08:42 UTC
Fair enough. But could we get this port reverted so that people could use it in the meantime?