Bug 257668 - Uses/cargo.mk: Build doesn't find the crate downloaded from gitlab
Summary: Uses/cargo.mk: Build doesn't find the crate downloaded from gitlab
Status: Closed Not A Bug
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Ports Framework (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Jan Beich
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-08-07 04:46 UTC by Yuri Victorovich
Modified: 2021-08-24 22:05 UTC (History)
2 users (show)

See Also:


Attachments
Makefile (6.44 KB, text/plain)
2021-08-07 04:46 UTC, Yuri Victorovich
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Yuri Victorovich freebsd_committer 2021-08-07 04:46:03 UTC
Created attachment 227002 [details]
Makefile

The attached port Makefile has the section generated with 'make cargo-crates' containing:

> GL_TUPLE=       https://gitlab.freedesktop.org:gstreamer:gstreamer-rs:f00c57cd6f2a0912e04c10887cedbe95be7d5dea:gstreamer \
>                 bilelmoussaoui:libadwaita-rs:2d09b6b566bc0fa2497612768cf0c41f582acdd7:libadwaita

'make configure' doesn't create the 'libadwaita*' directory under work/Shortwave-9bfc5ee2d857035cf0d3c72e211b3d76b85d7414/cargo-crates/ and the build fails:

> ===>  Configuring for shortwave-2.0.1
> error: failed to get `libadwaita` as a dependency of package `shortwave v0.0.0 (/usr/ports/multimedia/shortwave/work/Shortwave-9bfc5ee2d857035cf0d3c72e211b3d76b85d7414)`
Comment 1 Jan Beich freebsd_committer 2021-08-24 21:37:11 UTC
See ports ab415159b8b9 e.g., CARGO_GIT_SUBDIR=libadwaita:adw:libadwaita or audio/shortwave (since ports 957373794ec1).
Comment 2 Yuri Victorovich freebsd_committer 2021-08-24 22:04:43 UTC
Ok, thanks.