Bug 257746 - lang/python38: Fails to build: python38-3.8.11 is marked as BROKEN: incorrect pkg-plist.
Summary: lang/python38: Fails to build: python38-3.8.11 is marked as BROKEN: incorrect...
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: Fukang Chen
URL:
Keywords:
Depends on: 256558
Blocks:
  Show dependency treegraph
 
Reported: 2021-08-10 17:55 UTC by maximilian.lasser
Modified: 2021-08-20 00:32 UTC (History)
1 user (show)

See Also:
koobs: maintainer-feedback+


Attachments
buildlog, sort of. i guess (883 bytes, text/plain)
2021-08-12 21:59 UTC, maximilian.lasser
no flags Details
pkg version -v output, why though, i built from the ports tree (34.20 KB, text/plain)
2021-08-12 22:00 UTC, maximilian.lasser
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description maximilian.lasser 2021-08-10 17:55:40 UTC
Howdy partner,

i tried to build lang/python38 (3.8.11) with the DEBUG flag enabled and it yielded ´broken pkg-plist´. Disabling the debug flag fixed the issue.

This occured on a fresh FreeBSD 13.0 installation. It was literally one of the first packages i tried to install. I guess x11 or chromium pulled it in.

Here is my portmaster log showing previously installed packages:

Fri Aug  6 07:51:08 CEST 2021
	Installation of print/indexinfo (indexinfo-0.3.1)
	Installation of devel/gettext-runtime (gettext-runtime-0.21)
	Installation of devel/libtextstyle (libtextstyle-0.21)
	Installation of devel/gettext-tools (gettext-tools-0.21)
	Installation of devel/libffi (libffi-3.3_1)
	Installation of devel/readline (readline-8.0.4)
	Installation of lang/python37 (python37-3.7.9_1)

I installed python37 then instead of python38 because i had no idea how to fix the error and didn´t come back to it before Aug 9.

That's all i got. Not sure what information you would need but i also thought it would be a shame not to tell anyone.
Comment 1 Kubilay Kocak freebsd_committer freebsd_triage 2021-08-11 01:04:16 UTC
Thank you for your reeport. Could you please include additional information, including:

- uname -a output
- full build log output (as an attachment, compressed if necessary)
- /etc/make.conf contents (as an attachment) if not empty
- pkg version -v output (as an attachment)
- Q: Do any other Python port versions fail in the same way?
Comment 2 maximilian.lasser 2021-08-12 21:59:59 UTC
Created attachment 227147 [details]
buildlog, sort of. i guess
Comment 3 maximilian.lasser 2021-08-12 22:00:54 UTC
Created attachment 227148 [details]
pkg version -v output, why though, i built from the ports tree
Comment 4 maximilian.lasser 2021-08-12 22:04:14 UTC
i attached the "buildlog" - not sure if i am generating it right.
what i did:
make rmconfig
make configure (setting DEBUG=ON)
portmaster lang/python38
and copy paste of that output to a file
the issue was reproducible on my machine (the python38 reinstallation failed with the same error after setting DEBUG=ON)

uname -a
FreeBSD <hostname> 13.0-RELEASE FreeBSD 13.0-RELEASE #0 releng/13.0-n244733-ea31abc261f: Fri Apr  9 04:24:09 UTC 2021     root@releng1.nyi.freebsd.org:/usr/obj/usr/src/amd64.amd64/sys/GENERIC  amd64

/etc/make.conf did not exist at this point. right now it exists but is empty 

- Q: Do any other Python port versions fail in the same way?
A: no everything else compiled fine yet
Comment 5 Kubilay Kocak freebsd_committer freebsd_triage 2021-08-13 03:24:57 UTC
(In reply to maximilian.lasser from comment #3)

Building a port runs a make package, for installation, which is then registered using pkg(8). That is to say, pkg(8) is a frontend for binary package repositories *and* a package registration system (that ports use)
Comment 6 Kubilay Kocak freebsd_committer freebsd_triage 2021-08-13 03:27:43 UTC
Right, so BROKEN was added in the ports 2d2c2821bca5933475c6c418057f1480b85ded9b [1] as a workaround for resolving the issue, currently being tracked in bug 256558

[1] https://cgit.freebsd.org/ports/commit/?id=2d2c2821bca5933475c6c418057f1480b85ded9b
Comment 7 maximilian.lasser 2021-08-13 07:20:07 UTC
Ok so its intentional and you / the maintaining team is aware of it. Great. This one can be closed then i suppose. Thanks
Comment 8 Kubilay Kocak freebsd_committer freebsd_triage 2021-08-20 00:32:34 UTC
^Triage: Resolved via bug 256558, Assign to committer that resolved

@Reporter, If there is still an issue after updating to latest versions of ports or their respective packages, please re-open the issue with additional detail