Bug 257858 - net-im/gajim can not start because it looks for machine-id in the wrong directory
Summary: net-im/gajim can not start because it looks for machine-id in the wrong direc...
Status: Closed Unable to Reproduce
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Many People
Assignee: Ruslan Makhmatkhanov
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-08-15 12:11 UTC by Goran Mekić
Modified: 2021-10-19 08:01 UTC (History)
0 users

See Also:
bugzilla: maintainer-feedback? (rm)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Goran Mekić 2021-08-15 12:11:22 UTC
When I try to run gajim I get the following error.

gajim
No translations found
Dirs searched: [PosixPath('/usr/home/meka/.local/share'), PosixPath('/usr/local/share'), PosixPath('/usr/share')]
08/15/21 14:08:35 (W) gajim.c.storage.cache      Execution time for _load_caps_data: 170 ms
Traceback (most recent call last):
  File "/usr/local/lib/python3.8/site-packages/gajim/application.py", line 233, in _startup
    self.interface = Interface()
  File "/usr/local/lib/python3.8/site-packages/gajim/gui_interface.py", line 2068, in __init__
    music_track.enable()
  File "/usr/local/lib/python3.8/site-packages/gajim/common/dbus/music_track.py", line 208, in enable
    listener.start()
  File "/usr/local/lib/python3.8/site-packages/gajim/common/dbus/music_track.py", line 61, in start
    proxy = Gio.DBusProxy.new_for_bus_sync(
gi.repository.GLib.Error: g-file-error-quark: Cannot spawn a message bus without a machine-id: Unable to load /var/local/lib/dbus/machine-id or /etc/machine-id: Failed to open file “/var/local/lib/dbus/machine-id”: No such file or directory (4)
08/15/21 14:08:35 (W) gajim.gui.notification     Notifications D-Bus not available: g-file-error-quark: Cannot spawn a message bus without a machine-id: Unable to load /var/local/lib/dbus/machine-id or /etc/machine-id: Failed to open file “/var/local/lib/dbus/machine-id”: No such file or directory (4)


In short it should look in /var/lib/dbus/machine-id instead of /var/local/lib/dbus/machine-id.
Comment 1 p5B2E9A8F 2021-08-22 12:54:22 UTC
Confirming bug. Same here. 
Please change importance to many people as it affects users communications.
Comment 2 Ruslan Makhmatkhanov freebsd_committer 2021-10-15 13:22:07 UTC
Hello. 

It is definitely not the problem of gajim itself. I tried to grep for machine-id in source and found out no references. Do you use any third-party plugins, that are not included into gajim source? 

Looks like this dbus bug related: https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=228001

Anyway, I can't reproduce right now with version 1.3.3. Does it work for you now?