Bug 257935 - devel/notcurses: Update to 2.3.15
Summary: devel/notcurses: Update to 2.3.15
Status: Closed DUPLICATE of bug 257936
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: freebsd-ports-bugs (Nobody)
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-08-19 04:27 UTC by Nick Black
Modified: 2021-08-19 06:43 UTC (History)
1 user (show)

See Also:


Attachments
git diff 2.3.12 -> 2.3.15 (1.33 KB, patch)
2021-08-19 04:27 UTC, Nick Black
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Nick Black 2021-08-19 04:27:22 UTC
Created attachment 227315 [details]
git diff 2.3.12 -> 2.3.15

New upstream 2.3.15:

https://github.com/dankamongmen/notcurses/releases/tag/v2.3.15
https://github.com/dankamongmen/notcurses/releases/tag/v2.3.13

Most of the relevant material would be from 2.3.13 (2.3.15 was mainly devoted to porting to Microsoft Windows). 2.3.13 knocked out several bugs in notcurses-demo, plugs a leak in the Kitty renderer, and forces EGCs across Unicode ZWJ (zero-width join) characters.
Comment 1 Li-Wen Hsu freebsd_committer 2021-08-19 06:43:35 UTC

*** This bug has been marked as a duplicate of bug 257936 ***