Bug 257941 - sysutils/monit: check program keeps in state "waiting" forever
Summary: sysutils/monit: check program keeps in state "waiting" forever
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: freebsd-ports-bugs (Nobody)
URL:
Keywords: needs-patch
Depends on:
Blocks:
 
Reported: 2021-08-19 10:36 UTC by Ole
Modified: 2021-09-20 21:33 UTC (History)
3 users (show)

See Also:
martinp: maintainer-feedback?


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ole 2021-08-19 10:36:46 UTC
After upgrading monit from 5.28.0 to 5.28.1 program checks keep in the state "waiting" forever.
I discovered this on FreeBSD 12.2 and 13.0 RELEASE. 
A monit summary output looks like these:

┌─────────────────────────────────┬────────────────────────────┬───────────────┐
│ Service Name                    │ Status                     │ Type          │
├─────────────────────────────────┼────────────────────────────┼───────────────┤
│ 11-xxxxxxxxxxx-1.xxx.xx         │ OK                         │ System        │
├─────────────────────────────────┼────────────────────────────┼───────────────┤
│ syslog-ng                       │ OK                         │ Process       │
├─────────────────────────────────┼────────────────────────────┼───────────────┤
│ node_exporter                   │ OK                         │ Process       │
├─────────────────────────────────┼────────────────────────────┼───────────────┤
│ nginx                           │ OK                         │ Process       │
├─────────────────────────────────┼────────────────────────────┼───────────────┤
│ check_pkg_audit                 │ Waiting                    │ Program       │
├─────────────────────────────────┼────────────────────────────┼───────────────┤
│ xxxxxxxxx                       │ Waiting                    │ Program       │
├─────────────────────────────────┼────────────────────────────┼───────────────┤
│ yyyyyyyyy                       │ Waiting                    │ Program       │
├─────────────────────────────────┼────────────────────────────┼───────────────┤
│ cert_fetch                      │ Waiting                    │ Program       │
└─────────────────────────────────┴────────────────────────────┴───────────────┘


If you need more debug information please let me know

Ole
Comment 2 Ole 2021-08-20 10:08:16 UTC
If you need a hotfix for building this port with poudriere,
I discussed it on the mailing list

https://lists.freebsd.org/pipermail/freebsd-questions/2021-August/294601.html
Comment 3 Fernando Apesteguía freebsd_committer 2021-08-20 12:31:19 UTC
Ole, thanks for reporting this.

Martin, what do you mean by "Approving" this? There is no patch attached to the PR. Maybe we can add the hotfix as a patch in files?
Comment 4 Martin Pala 2021-08-22 17:56:31 UTC
I'm sorry Fernando, i did set the maintainer-feedback to '+' to confirm the problem. As mentioned in the comments, the problem is fixed upstream (https://bitbucket.org/tildeslash/monit/commits/47e042610940)

A new Monit version (5.29.0) will be released in ca. 2-3 days, i think we can wait (?) for that release, which would resolved this bug.
Comment 5 Fernando Apesteguía freebsd_committer 2021-08-22 20:15:16 UTC
(In reply to Martin Pala from comment #4)
That is OK for me. Thanks a lot for the clarification about the flag.
Comment 6 Martin Pala 2021-08-24 18:01:13 UTC
The port update was just submitted: https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=258029
Comment 7 commit-hook freebsd_committer 2021-08-25 07:46:06 UTC
A commit in branch main references this bug:

URL: https://cgit.FreeBSD.org/ports/commit/?id=6234479982621235dc99824a812cd9ee11dbbf93

commit 6234479982621235dc99824a812cd9ee11dbbf93
Author:     Martin Pala <martinp@tildeslash.com>
AuthorDate: 2021-08-25 06:51:41 +0000
Commit:     Fernando Apesteguía <fernape@FreeBSD.org>
CommitDate: 2021-08-25 07:40:25 +0000

    sysutils/monit: Update to 5.29.0

    ChangeLog: https://www.mmonit.com/monit/changes/

    This release fixes an issue reported in PR 257941

    PR:     258029 257941
    Reported by:    martinp@tildeslash.com (maintainer)

 sysutils/monit/Makefile | 4 ++--
 sysutils/monit/distinfo | 6 +++---
 2 files changed, 5 insertions(+), 5 deletions(-)
Comment 8 Fernando Apesteguía freebsd_committer 2021-08-25 07:55:23 UTC
Fixed in bug #258029

Thanks!
Comment 9 commit-hook freebsd_committer 2021-09-20 21:33:17 UTC
A commit in branch 2021Q3 references this bug:

URL: https://cgit.FreeBSD.org/ports/commit/?id=497ca938c5ed7eff2cf441a4ffee4843d2345c5b

commit 497ca938c5ed7eff2cf441a4ffee4843d2345c5b
Author:     Martin Pala <martinp@tildeslash.com>
AuthorDate: 2021-08-25 06:51:41 +0000
Commit:     Bryan Drewery <bdrewery@FreeBSD.org>
CommitDate: 2021-09-20 21:32:05 +0000

    sysutils/monit: Update to 5.29.0

    ChangeLog: https://www.mmonit.com/monit/changes/

    This release fixes an issue reported in PR 257941

    PR:     258029 257941
    Reported by:    martinp@tildeslash.com (maintainer)

    (cherry picked from commit 6234479982621235dc99824a812cd9ee11dbbf93)

 sysutils/monit/Makefile | 4 ++--
 sysutils/monit/distinfo | 6 +++---
 2 files changed, 5 insertions(+), 5 deletions(-)