Bug 257977 - devel/glib20: unbreak machine-id lookup after 2.68 update
Summary: devel/glib20: unbreak machine-id lookup after 2.68 update
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: freebsd-desktop (Team)
URL:
Keywords: patch, regression
: 258054 258403 (view as bug list)
Depends on:
Blocks:
 
Reported: 2021-08-21 03:28 UTC by Jan Beich
Modified: 2021-09-20 00:59 UTC (History)
5 users (show)

See Also:
tcberner: maintainer-feedback+


Attachments
v1 (2.31 KB, patch)
2021-08-21 03:28 UTC, Jan Beich
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Jan Beich freebsd_committer 2021-08-21 03:28:40 UTC
Created attachment 227350 [details]
v1

Regressed by https://gitlab.gnome.org/GNOME/glib/-/commit/05ff2f877ca3. glib bindings for dbus no longer work without /etc/machine-id symlink.

$ pkg install gtk4
$ service dbus onestart
$ cat /var/lib/dbus/machine-id
123456789012345678901234567890123
$ gtk4-demo
Gdk-Message: Failed to get file transfer portal: Cannot spawn a message bus without a machine-id: Unable to load /var/local/lib/dbus/machine-id or /etc/machine-id: Failed to open file “/var/local/lib/dbus/machine-id”: No such file or directory
^C

$ pkg install squeekboard
$ squeekboard &
Can't connect to the bus: Cannot spawn a message bus without a machine-id: Unable to load /var/local/lib/dbus/machine-id or /etc/machine-id: Failed to open file “/var/local/lib/dbus/machine-id”: No such file or directory. Visibility switching unavailable.
** (squeekboard:1234): WARNING **: Could not connect to session manager: Cannot spawn a message bus without a machine-id: Unable to load /var/local/lib/dbus/machine-id or /etc/machine-id: Failed to open file “/var/local/lib/dbus/machine-id”: No such file or directory
$ gdbus call --session \
             --dest=sm.puri.OSK0 \
             --object-path=/sm/puri/OSK0 \
             --method=sm.puri.OSK0.SetVisible \
             true
Error connecting: Cannot spawn a message bus without a machine-id: Unable to load /var/local/lib/dbus/machine-id or /etc/machine-id: Failed to open file “/var/local/lib/dbus/machine-id”: No such file or directory
Comment 1 Tobias C. Berner freebsd_committer 2021-08-28 05:55:40 UTC
ship it
Comment 2 commit-hook freebsd_committer 2021-08-28 06:04:59 UTC
A commit in branch main references this bug:

URL: https://cgit.FreeBSD.org/ports/commit/?id=769efa05cf4c27f16b30286b258b8f0738acc345

commit 769efa05cf4c27f16b30286b258b8f0738acc345
Author:     Jan Beich <jbeich@FreeBSD.org>
AuthorDate: 2021-08-21 03:03:06 +0000
Commit:     Jan Beich <jbeich@FreeBSD.org>
CommitDate: 2021-08-28 06:04:08 +0000

    devel/glib20: unbreak session bus autolaunch after 94630ac169bc

    Regressed by https://gitlab.gnome.org/GNOME/glib/-/commit/05ff2f877ca3

    $ pkg install gtk4
    $ service dbus onestart
    $ cat /var/lib/dbus/machine-id
    123456789012345678901234567890123
    $ unset DBUS_SESSION_BUS_ADDRESS XDG_RUNTIME_DIR
    $ gtk4-demo
    Gdk-Message: Failed to get file transfer portal: Cannot spawn a message bus without a machine-id: Unable to load /var/local/lib/dbus/machine-id or /etc/machine-id: Failed to open file “/var/local/lib/dbus/machine-id”: No such file or directory
    ^C
    $ gdbus call --session --dest=org.freedesktop.DBus --object-path=/ --method=org.freedesktop.DBus.ListNames
    Error connecting: Cannot spawn a message bus without a machine-id: Unable to load /var/local/lib/dbus/machine-id or /etc/machine-id: Failed to open file “/var/local/lib/dbus/machine-id”: No such file or directory

    PR:             257977
    Tested by:      Thibault Payet
    Approved by:    tcberner

 devel/glib20/Makefile | 3 ++-
 1 file changed, 2 insertions(+), 1 deletion(-)
Comment 3 Jan Beich freebsd_committer 2021-08-28 06:05:32 UTC
*** Bug 258054 has been marked as a duplicate of this bug. ***
Comment 4 Kubilay Kocak freebsd_committer freebsd_triage 2021-09-20 00:59:15 UTC
*** Bug 258403 has been marked as a duplicate of this bug. ***