Bug 258020 - dns/knot-resolver: Update to 5.4.1
Summary: dns/knot-resolver: Update to 5.4.1
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: freebsd-ports-bugs (Nobody)
URL: https://www.knot-resolver.cz/2021-08-...
Keywords: easy
Depends on:
Blocks:
 
Reported: 2021-08-24 09:46 UTC by Leo Vandewoestijne
Modified: 2021-09-11 18:36 UTC (History)
2 users (show)

See Also:
kbowling: merge-quarterly-


Attachments
knot-resolver 5.4.1 (976 bytes, patch)
2021-08-24 09:46 UTC, Leo Vandewoestijne
freebsd: maintainer-approval+
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Leo Vandewoestijne 2021-08-24 09:46:16 UTC
Created attachment 227398 [details]
knot-resolver 5.4.1

Last week knot-resolver 5.4.0 was released.
This patch updates the port accordingly.

It only contains minor bugfixes, and so it's all simple, but anyway I tested (succesfully) with portlint, portclippy, portfmt, poudriere.
Comment 1 Kubilay Kocak freebsd_committer freebsd_triage 2021-08-24 09:51:01 UTC
Thank you Leo

If quarterly users are impacted by issues resolved in this (bugfix release), and it should be merged, please set merge-quarterly flag to ?
Comment 2 commit-hook freebsd_committer 2021-08-24 19:40:03 UTC
A commit in branch main references this bug:

URL: https://cgit.FreeBSD.org/ports/commit/?id=891136458afa9b0669907014bcd7875e43cfe69b

commit 891136458afa9b0669907014bcd7875e43cfe69b
Author:     Leo Vandewoestijne <freebsd@dns.company>
AuthorDate: 2021-08-24 19:37:40 +0000
Commit:     Nuno Teixeira <eduardo@FreeBSD.org>
CommitDate: 2021-08-24 19:39:30 +0000

    dns/knot-resolver: Update to 5.4.1

    ChangeLog: https://www.knot-resolver.cz/2021-08-19-knot-resolver-5.4.1.html

    PR:             258020

 dns/knot-resolver/Makefile | 2 +-
 dns/knot-resolver/distinfo | 6 +++---
 2 files changed, 4 insertions(+), 4 deletions(-)
Comment 3 Nuno Teixeira freebsd_committer 2021-08-24 20:21:56 UTC
(In reply to Kubilay Kocak from comment #1)
Hello,

I'm trying to commit this to Q3:

> git switch 2021Q3
> git cherry-pick -x git 891136458afa9b0669907014bcd7875e43cfe69b
> git commit
> git push --push-option=confirm-author

But I'm having some conflicts with Makefile and distinfo and push is rejected.

Could you please do this Q3 update and tell me what did you do?
Comment 4 Kubilay Kocak freebsd_committer freebsd_triage 2021-08-25 00:48:45 UTC
(In reply to Nuno Teixeira from comment #3)

What/where are the conflicts? Perhaps an intervening non-merged commit is the cause
Comment 5 Leo Vandewoestijne 2021-08-25 09:30:06 UTC
(In reply to Kubilay Kocak from comment #4)
This port used to be merged, but that was stopped at one point, long ago.
But since few weeks (so during this quarter) it is again.
So yes, maybe that's the cause?
Comment 6 Kevin Bowling freebsd_committer 2021-09-11 18:36:10 UTC
(In reply to Nuno Teixeira from comment #3)
This kind of change (5.3 -> 5.4) would not generally be suitable for MFH unless there is no other way to proceed for urgent fixes.