Bug 258164 - net-mgmt/netbox: can not assign net interface to virtual machine
Summary: net-mgmt/netbox: can not assign net interface to virtual machine
Status: Open
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Many People
Assignee: Kai Knoblich
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-08-30 08:02 UTC by O. Hartmann
Modified: 2021-08-30 09:08 UTC (History)
0 users

See Also:
kai: maintainer-feedback+


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description O. Hartmann 2021-08-30 08:02:58 UTC
net-mgmt/netbox v2.11.11 as of today fails since a couple of months for now to be capable of assigning a network interface to a virtual machine.

I can't say when this has been "introduced" to FreeBSD's port. A couple of months ago, we created VMs in netbox an we were capable of assigning a vNIC and then the appropriate IP. This is no longer possible.
Comment 1 Kai Knoblich freebsd_committer 2021-08-30 09:08:47 UTC
(In reply to O. Hartmann from comment #0)

Thank you for the report.  I tried to reproduce it in my test environment, but it worked fine for me with NetBox 2.11.11 so far.

I was able to create a new VM with a NIC and assign an IP address to it via the web interface.  But I do remember, however, that NetBox 2.9 had a significant change related to VM interfaces.

In order to better isolate the problem, I need a few more information:

- Does the problem occur via the web interface or via scripting?

- What is the error message that is being generated?