Bug 258252 - FreeBSD 13.0 xorg installation does not run on pure UEFI system.
Summary: FreeBSD 13.0 xorg installation does not run on pure UEFI system.
Status: New
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: amd64 Any
: --- Affects Only Me
Assignee: freebsd-x11 (Nobody)
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-09-03 16:08 UTC by Karel Gardas
Modified: 2021-09-17 15:22 UTC (History)
3 users (show)

See Also:


Attachments
Xorg log (5.36 KB, text/plain)
2021-09-03 16:08 UTC, Karel Gardas
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Karel Gardas 2021-09-03 16:08:03 UTC
Created attachment 227646 [details]
Xorg log

Hello,

following handbook, I've done completely clean installation of FreeBSD 13.0 on amd64 machine (kontron board + W-2123 + 8GB RAM + AMD R5 230 1GB GPU.

I've installed xorg by:

# pkg install xorg

and then on a user in wheel group I've attempted to start X by:

$ startx

the result is:

xauth:  file /home/karel/.serverauth.36307 does not exist


X.Org X Server 1.20.11
X Protocol Version 11, Revision 0
Build Operating System: FreeBSD 13.0-RELEASE-p4 amd64 
Current Operating System: FreeBSD freebsd 13.0-RELEASE FreeBSD 13.0-RELEASE #0 releng/13.0-n244733-ea31abc261f: Fri Apr  9 04:24:09 UTC 2021     root@releng1.nyi.freebsd.org:/usr/obj/usr/src/amd64.amd64/sys/GENERIC amd64
Build Date: 26 August 2021  07:50:47AM
 
Current version of pixman: 0.40.0
        Before reporting problems, check http://wiki.x.org
        to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
        (++) from command line, (!!) notice, (II) informational,
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Fri Sep  3 18:05:32 2021
(==) Using system config directory "/usr/local/share/X11/xorg.conf.d"
scfb trace: probe start
scfb trace: probe done
(EE) 
Fatal server error:
(EE) Cannot run in framebuffer mode. Please specify busIDs        for all framebuffer devices
(EE) 
(EE) 
Please consult the The X.Org Foundation support 
         at http://wiki.x.org
 for help. 
(EE) Please also check the log file at "/var/log/Xorg.0.log" for additional information.
(EE) 
(EE) Server terminated with error (1). Closing log file.


Recommended Xorg.0.log is attached to this report too.

Now, my question is how to proceed as handbook concentrate attention to possibly old platforms/system and not new one like pure UEFI + fb.

Thanks!
Karel
Comment 1 Karel Gardas 2021-09-04 20:23:19 UTC
I've digged a bit deeper and it looks like this is well known issue of conflict between AMD GPU based EFI fb and between accelerated driver for it inside FreeBSD.

https://wiki.freebsd.org/Graphics
https://github.com/freebsd/drm-kmod/issues/60

So I would guess this issue may be closed.
Comment 2 Niclas Zeising freebsd_committer 2021-09-17 15:10:22 UTC
FreeBSD graphics work on UEFI systems, I use them there myself.

Have you tried following the instructions and disabling the console until the GPU driver is loaded?  Have you even tried to install and load the GPU driver?
Comment 3 Karel Gardas 2021-09-17 15:22:40 UTC
Hi Niclas,

of course I have tried. In fact it may not be obvious from my discovery email, but I've tried:

- load amd radeon drm kernel module (this disables console for some time) and then start xserver -- works well

- configure recommended /usr/local/etc/X11/xorg.conf.d/driver-scfb.conf with recommended content and then xserver works well too.

So what this issue is about is:

- *if* handbook is ultimate user reference, then it's outdated since issue of UEFI+AMD conflict is not mentioned there (on X11 related page(s)).

- simple "pkg install xorg; startx" is not working by default on UEFI+AMD. You need to do quite some googling around, avoid misleading handbook info and find out the right information how and what to do.

Fortunately when https://github.com/freebsd/drm-kmod/issues/60 fix propagates to release, it will solve the issue. I've not had a chance to test it yet though.

Thanks!