Bug 258256 - emulators/virtualbox-ose-nox11: depends on Qt5
Summary: emulators/virtualbox-ose-nox11: depends on Qt5
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Guido Falsi
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-09-03 17:26 UTC by Lapo Luchini
Modified: 2021-09-03 20:05 UTC (History)
3 users (show)

See Also:
madpilot: maintainer-feedback+
madpilot: merge-quarterly-


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Lapo Luchini 2021-09-03 17:26:56 UTC
Hi. This is maybe right (?), but unexpected to me (a "no X11" port to depend on anything GUI-related):

% pkg info -r qt5-gui
qt5-gui-5.15.2_6:
        virtualbox-ose-nox11-6.1.26

% pkg info -d virtualbox-ose-nox11
virtualbox-ose-nox11-6.1.26:
        qt5-x11extras-5.15.2_1
        libxcb-1.14_1
        libXinerama-1.1.4_2,1
        libXext-1.3.4,1
        libXcursor-1.2.0
        libX11-1.7.2,1
        qt5-widgets-5.15.2_3
        qt5-gui-5.15.2_6
        pango-1.48.7
        libXt-1.2.1,1
        libXmu-1.1.3,1
        libxslt-1.1.34_2
        libxml2-2.9.12
        qt5-printsupport-5.15.2_1
        libvncserver-0.9.13_1
        qt5-opengl-5.15.2_2
        png-1.6.37_1
        libglvnd-1.3.3
        libGLU-9.0.2_1
        gtk-update-icon-cache-3.24.26
        gdk-pixbuf2-2.40.0
        curl-7.78.0
        virtualbox-ose-kmod-6.1.26
        sdl-1.2.15_15,2
        qt5-dbus-5.15.2_1
        qt5-core-5.15.2_5
        libIDL-0.8.14_5
        glib-2.68.4,2
        gettext-runtime-0.21
        dbus-1.12.20_5
        atk-2.36.0

This on FreeBSD 13.0-RELEASE-p4 amd64 using "latest" pkg.conf.
Comment 1 Guido Falsi freebsd_committer 2021-09-03 17:35:47 UTC
Lapo asked me about this strangeness and I asked him to file a bug report. I can't dig much right now, but a look at the slave ports tells me it has correct OPTIONS_EXCLUDE, but they are not actually applied to the port.

This could be my fault for using OPTIONS_EXCLUDE to remove the PULSEAUDIO option. So I'm going to fix this b disabling it the old fashioned way.
Comment 2 Guido Falsi freebsd_committer 2021-09-03 17:59:12 UTC
No need to merge to quarterly since the change causing the issue is not included there.
Comment 3 commit-hook freebsd_committer 2021-09-03 19:58:52 UTC
A commit in branch main references this bug:

URL: https://cgit.FreeBSD.org/ports/commit/?id=1dfc4d117b71085ec0351310d6ee435622b53ada

commit 1dfc4d117b71085ec0351310d6ee435622b53ada
Author:     Guido Falsi <madpilot@FreeBSD.org>
AuthorDate: 2021-09-03 19:49:46 +0000
Commit:     Guido Falsi <madpilot@FreeBSD.org>
CommitDate: 2021-09-03 19:58:08 +0000

    emulators/virtualbox-ose: Avoid overwriting slave ports OPTIONS_EXCLUDE

    To disable the PULSEAUDIO option I used the OPTIONS_EXCLUDE variable
    in commit 416b34d584e268.

    Turns out this overwrites OPTIONS_EXCLUDE from slave ports. I'm
    fixing this by only adding the PULSEAUDIO exclusion to the existing
    EXCLUDE variable if defined.

    NOTE: While it would be enough to bump PORTREVISION in the slave
    port, I'm bumping PORTREVISION on master port to avoid adding
    variables that are easily forgotten in future changes and could
    cause even more breakage.

    PR:             258256
    Pointy Hat:     myself

 emulators/virtualbox-ose/Makefile | 3 ++-
 1 file changed, 2 insertions(+), 1 deletion(-)