Bug 258268 - emulators/wine specify the FreeBSD repository when dropping the hint for /usr/local/share/wine/pkg32.sh
Summary: emulators/wine specify the FreeBSD repository when dropping the hint for /usr...
Status: Closed Works As Intended
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Gerald Pfeifer
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-09-05 01:37 UTC by Graham Perrin
Modified: 2021-10-06 05:57 UTC (History)
3 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Graham Perrin 2021-09-05 01:37:36 UTC
% pkg info -x wine
wine-6.0.1_2,1
wine-proton-6.3.2_2
winetricks-20210617
% winecfg
/home/grahamperrin/.i386-wine-pkg//usr/local/bin/wine doesn't exist!

Try installing 32-bit Wine with
        /usr/local/share/wine/pkg32.sh install wine mesa-dri
% /usr/local/share/wine/pkg32.sh install wine mesa-dri
pkg -o ABI=FreeBSD:14:i386 -o INSTALL_AS_USER=true -o RUN_SCRIPTS=false --rootdir /home/grahamperrin/.i386-wine-pkg install wine mesa-dri
Updating FreeBSD repository catalogue...
FreeBSD repository is up to date.
Updating poudriere repository catalogue...
Fetching meta.conf: 100%    163 B   0.2kB/s    00:01    
Fetching packagesite.pkg: 100%    3 KiB   3.2kB/s    00:01    
Processing entries:   0%
pkg: wrong architecture: FreeBSD:14:amd64 instead of FreeBSD:14:i386
pkg: repository poudriere contains packages with wrong ABI: FreeBSD:14:amd64
Processing entries: 100%
Unable to update repository poudriere
Error updating repositories!
% /usr/local/share/wine/pkg32.sh install -r FreeBSD wine mesa-dri
pkg -o ABI=FreeBSD:14:i386 -o INSTALL_AS_USER=true -o RUN_SCRIPTS=false --rootdir /home/grahamperrin/.i386-wine-pkg install -r FreeBSD wine mesa-dri
Updating FreeBSD repository catalogue...
FreeBSD repository is up to date.
All repositories are up to date.
The following 5 package(s) will be affected (of 0 checked):

New packages to be INSTALLED:
        libGLU: 9.0.2_1 [FreeBSD]
        llvm12: 12.0.1_4 [FreeBSD]
        lua53: 5.3.6 [FreeBSD]
        wine: 6.0.1_2,1 [FreeBSD]

Installed packages to be UPGRADED:
        mesa-dri: 20.2.3_2 -> 21.1.5 [FreeBSD]

Number of packages to be installed: 4
Number of packages to be upgraded: 1

The process will require 941 MiB more space.
156 MiB to be downloaded.

Proceed with this action? [y/N]: y
[1/5] Fetching wine-6.0.1_2,1.pkg: 100%   28 MiB   5.9MB/s    00:05    
[2/5] Fetching mesa-dri-21.1.5.pkg: 100%   12 MiB   4.2MB/s    00:03    
[3/5] Fetching libGLU-9.0.2_1.pkg: 100%  209 KiB 214.3kB/s    00:01    
[4/5] Fetching llvm12-12.0.1_4.pkg: 100%  116 MiB   6.4MB/s    00:19    
[5/5] Fetching lua53-5.3.6.pkg: 100%  286 KiB 293.3kB/s    00:01    
Checking integrity... done (0 conflicting)
[1/5] Installing lua53-5.3.6...
[1/5] Extracting lua53-5.3.6: 100%
[2/5] Installing libGLU-9.0.2_1...
[2/5] Extracting libGLU-9.0.2_1: 100%
[3/5] Installing llvm12-12.0.1_4...
[3/5] Extracting llvm12-12.0.1_4: 100%
[4/5] Installing wine-6.0.1_2,1...
[4/5] Extracting wine-6.0.1_2,1: 100%
[5/5] Upgrading mesa-dri from 20.2.3_2 to 21.1.5...
[5/5] Extracting mesa-dri-21.1.5: 100%
=====
Message from wine-6.0.1_2,1:

--
Some ZFS tuning guides recommend setting KVA_PAGES=512 in your kernel
configuration.  This is incompatible with Wine.  The maximum possible
is KVA_PAGES=500, which should still be enough for ZFS.

The port also installs some of Wine's documentation which describes
additional programs that are not in the manual pages under
  /usr/local/share/doc/wine
There is more in the source tree but the others are only useful in
conjunction with the rest of the source tree.
% winecfg
…
Comment 1 Gerald Pfeifer freebsd_committer 2021-09-23 18:29:14 UTC
Do you want to propose concrete wording, Graham?

Alex, FYI, since you originally proposed this IIRC, so maybe you have
a suggestion?
Comment 2 Alex S 2021-09-23 19:06:33 UTC
(In reply to Gerald Pfeifer from comment #1)

> Alex, FYI, since you originally proposed this IIRC, so maybe you have
a suggestion?

Not at the moment, no. There doesn't exist a single command working for all cases.
Comment 3 Gerald Pfeifer freebsd_committer 2021-10-06 05:57:19 UTC
Alex (or Damjan) if you later have an idea on how to address this,
please advise.

Graham, it appears there is no good way to tackle this for all cases,
and you also didn't propose one, so I am closing this. (There isn't a
really fitting status, so using Works As Intended.)