Bug 258276 - net-p2p/gtk-gnutella: Update to 1.2.1 and take maintainership
Summary: net-p2p/gtk-gnutella: Update to 1.2.1 and take maintainership
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Alexey Dokuchaev
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-09-05 06:46 UTC by Chris Petrik
Modified: 2021-09-15 12:02 UTC (History)
2 users (show)

See Also:


Attachments
patch (1.57 KB, patch)
2021-09-05 06:46 UTC, Chris Petrik
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Chris Petrik 2021-09-05 06:46:06 UTC
Created attachment 227669 [details]
patch

Update to 1.2.1
Comment 1 commit-hook freebsd_committer 2021-09-15 11:57:12 UTC
A commit in branch main references this bug:

URL: https://cgit.FreeBSD.org/ports/commit/?id=9a32701b738f3ced9488bc558566cd6c01c46773

commit 9a32701b738f3ced9488bc558566cd6c01c46773
Author:     Alexey Dokuchaev <danfe@FreeBSD.org>
AuthorDate: 2021-09-15 11:55:32 +0000
Commit:     Alexey Dokuchaev <danfe@FreeBSD.org>
CommitDate: 2021-09-15 11:55:34 +0000

    net-p2p/gtk-gnutella: the port had been updated and improved (+)

    - Update to version 1.2.1, which now needs GNU make to build
    - Switch to SourceForge where official releases are published; this
      also means shorter distfile name, correctly preserved modification
      time, and alleviates the need for DISTVERSIONPREFIX abomination
    - Remove ONLY_FOR_ARCHS constraint: there should not be anything
      architecture-specific about server/client program for Gnutella,
      modulo some fragility in their custom memory allocator
    - Force previous (as in version 1.1.15) alignment value on i386 and
      likely other 32-bit architectures to unbreak the build there
    - Drop non-standard IRC line from the port description and improve
      creator's attribution while I'm here

    PR:     258276

 net-p2p/gtk-gnutella/Makefile  | 16 +++++++++-------
 net-p2p/gtk-gnutella/distinfo  |  6 +++---
 net-p2p/gtk-gnutella/pkg-descr |  1 -
 3 files changed, 12 insertions(+), 11 deletions(-)
Comment 2 Alexey Dokuchaev freebsd_committer 2021-09-15 12:02:02 UTC
Thanks for the update, committed with several modifications.  I've did not mark the port as MAKE_JOBS_UNSAFE=yes which was in your patch because I could not reproduce the breakage and you did not explain it and/or provide a build log with -jX-related error(s).