Bug 258413 - [exp-run] OpenSSL 3.0.0 upgrade
Summary: [exp-run] OpenSSL 3.0.0 upgrade
Status: New
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Ports Framework (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Many People
Assignee: Port Management Team
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-09-10 19:49 UTC by Bernard Spil
Modified: 2021-09-11 13:02 UTC (History)
3 users (show)

See Also:
lwhsu: exp-run?


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Bernard Spil freebsd_committer 2021-09-10 19:49:40 UTC
OpenSSL 3.0.0 has reached RELEASE status on 2021-09-07.

Requesting an exp-run on the full ports tree to test all ports for building against OpenSSL 3.0.0. We need to scope the fallout prior to switching security/openssl to OpenSSL 3.

> DEFAULT_VERSIONS+= openssl-devel

should show all fall-out on ports-tree.

NOTE: Not only build-errors exist, apache24 builds with OpenSSL 3.0.0 yet fails at runtime.
Comment 1 Daniel Engberg freebsd_committer 2021-09-11 13:02:00 UTC
Alpine Linux are doing this as we speak and there's a lot of fallout so to same time and effort we can probably look at their repo and fix ports that are known to fail.
https://git.alpinelinux.org/aports/log/