Bug 258549 - net-im/openfire -- incorrect version. Installs 4.6.2 but reports 4.6.4 in the port info
Summary: net-im/openfire -- incorrect version. Installs 4.6.2 but reports 4.6.4 in the...
Status: Closed Not Accepted
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: freebsd-ports-bugs (Nobody)
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-09-16 22:50 UTC by Masuji
Modified: 2021-09-17 03:26 UTC (History)
2 users (show)

See Also:
bugzilla: maintainer-feedback? (nikita)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Masuji 2021-09-16 22:50:53 UTC
This is an easy one to replicate:

Build Openfire, with ports or poudriere. Install the package. Go to the web interface. It reports 4.6.2 

I see back in june some changes were made to it to reverse a bug. Can someone confirm if this is related?
Comment 1 Nikita Druba 2021-09-16 23:48:41 UTC
Hi! 

Now port files in a correct condition. At my server builds correctly 4.6.4. Are you sure, that you port files updated? Please, attach Makefile and distfile from you /usr/ports/net-im/openfire.
Comment 2 Alexey Dokuchaev freebsd_committer 2021-09-17 03:26:38 UTC
The port had been updated to version 4.6.4 in https://cgit.freebsd.org/ports/commit/?id=3968e59f6c62174afa7f526544d902f2b507d0bb on June 26 (master/main branch) which made it to the current quarterly branch (2021Q3) forked on July 3.  Please update your ports tree to the supported configuration.

(In reply to Masuji from comment #0)
> Can someone confirm if this is related?
No, it is not related.