Bug 258622 - Default text editor - vi - is difficult to use for many, and most definitely not intuitive.
Summary: Default text editor - vi - is difficult to use for many, and most definitely ...
Status: Closed Not A Bug
Alias: None
Product: Base System
Classification: Unclassified
Component: misc (show other bugs)
Version: Unspecified
Hardware: Any Any
: --- Affects Many People
Assignee: Mark Linimon
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-09-20 05:11 UTC by Geezer
Modified: 2021-09-20 17:34 UTC (History)
3 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Geezer 2021-09-20 05:11:51 UTC
A text edit is essential.

The default text edit is vi. This is difficult to use for many, and most definitely not intuitive. One of the main difficulties is getting out of it.

This affect new users of Freebsd who may have never used a non-graphical system before. 

It also affects seasoned users. I have never liked vi, and often been stumped.

Esc - q - Bang - Enter
This is ridiculous!

It does not reflect the current general state of usability of Freebsd.

Included with Freebsd is the editor ee. This is simple, intuitive, and has instructions for use included at the top of the screen.

I recommend that the default editor be changed from vi to ee. 

Although I do understand that the environment variable EDITOR can be set to change the behaviour, the default editor should be completely usable in the first place.

Thank you.
Comment 1 Graham Perrin 2021-09-20 06:57:44 UTC
+1 to ee as the default. 

/ducks
Comment 2 Rodrigo Osorio freebsd_committer 2021-09-20 07:22:05 UTC
Hi,

This could be the right place for your proposal
https://github.com/freebsd/fcp

Just my two cents.
-- rodrigo
Comment 3 Marek Zarychta 2021-09-20 09:03:02 UTC
(In reply to Graham Perrin from comment #1)
>Esc - q - Bang - Enter
>This is ridiculous!

vi(1) is clear, intuitive, ergonomic and well known.
You can always change default editor to ee or anything else by setting appropriate value of $EDITOR.

>I recommend that the default editor be changed from vi to ee.
I and many users will object this, even occasionally for April Fool's day.

IMHO this is not a bug but the feature and the PR should be closed.
Comment 4 Mark Linimon freebsd_committer freebsd_triage 2021-09-20 09:27:23 UTC
FreeBSD is configurable enough to support administrators changing the default editor.

After 20+ years, I do not see it possible to change this default.
Comment 5 Kubilay Kocak freebsd_committer freebsd_triage 2021-09-20 09:30:50 UTC
Adding to previous comment:

If so inclined, I would suggest taking the proposal to the mailing lists in order to outline the case, and to build consensus.

If there are any concrete outcomes and support from that discussion, please don't hesitate to re-open the issue with additional detail, including any potential alternative proposals that arise.
Comment 6 Geezer 2021-09-20 10:01:54 UTC
Rodrigo Osorio and Kubilay Kocak, thank you for your unprejudiced, helpful and polite input.
Comment 7 Graham Perrin 2021-09-20 17:34:16 UTC
> Not A Bug

/ceases ducking

(In reply to Marek Zarychta from comment #3)

> intuitive

Frankly, hilarious.