Bug 258672 - www/node: fails to build on FreeBSD 12.2/13.0
Summary: www/node: fails to build on FreeBSD 12.2/13.0
Status: Closed Unable to Reproduce
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Bradley T. Hughes
URL:
Keywords: needs-patch
: 258744 258862 (view as bug list)
Depends on:
Blocks:
 
Reported: 2021-09-22 06:10 UTC by Jan Beich
Modified: 2021-10-04 07:56 UTC (History)
2 users (show)

See Also:
bugzilla: maintainer-feedback? (bhughes)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jan Beich freebsd_committer 2021-09-22 06:10:10 UTC
Probably regressed by 54ac71cd2998.

$ poudriere testport -j 130amd64 www/node
[...]
ld: error: undefined symbol: RSA_get0_pss_params
>>> referenced by crypto_rsa.cc
>>>               crypto_rsa.o:(node::crypto::GetRsaKeyDetail(node::Environment*, std::__1::shared_ptr<node::crypto::KeyObjectData>, v8::Local<v8::Object>)) in archive /wrkdirs/usr/ports/www/node/work/node-v16.9.1/out/Release/obj.target/libnode.a
c++: error: linker command failed with exit code 1 (use -v to see invocation)

$ poudriere testport -j 122amd64 www/node
[...]
ld: error: undefined symbol: RSA_get0_pss_params
>>> referenced by crypto_rsa.cc
>>>               crypto_rsa.o:(node::crypto::GetRsaKeyDetail(node::Environment*, std::__1::shared_ptr<node::crypto::KeyObjectData>, v8::Local<v8::Object>)) in archive /wrkdirs/usr/ports/www/node/work/node-v16.9.1/out/Release/obj.target/libnode.a
c++: error: linker command failed with exit code 1 (use -v to see invocation)
Comment 1 Bradley T. Hughes freebsd_committer 2021-09-22 08:11:16 UTC
These functions were added in OpenSSL 1.1.1e, but were not exported until after https://www.freebsd.org/security/advisories/FreeBSD-EN-21:24.libcrypto.asc. If you update your jails, www/node should build :)
Comment 2 Jan Beich freebsd_committer 2021-09-22 14:13:50 UTC
I confirm, builds fine on 12.2/13.0 after running freebsd-update via poudriere jail -u.
Comment 3 Bradley T. Hughes freebsd_committer 2021-09-27 16:25:22 UTC
*** Bug 258744 has been marked as a duplicate of this bug. ***
Comment 4 Bradley T. Hughes freebsd_committer 2021-10-04 07:56:34 UTC
*** Bug 258862 has been marked as a duplicate of this bug. ***