Bug 258723 - x11-wm/qtile black screen
Summary: x11-wm/qtile black screen
Status: Open
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: amd64 Any
: --- Affects Only Me
Assignee: Eric Turgeon
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-09-25 18:36 UTC by b1ru
Modified: 2021-09-29 14:33 UTC (History)
0 users

See Also:
bugzilla: maintainer-feedback? (ericbsd)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description b1ru 2021-09-25 18:36:20 UTC
I get a black screen when I try to use qtile.
No cursor and no default bindings working.

My .xinitrc is like this:

    exec qtile start

I also tried this, this did not work either:

    exec qtile 

The weird thing is when I tried this, it actually worked!

   qtile start&
   exec xterm

Of course, this isn't an ideal solution because If I close xterm, X closes too.

My FreeBSD version is:  13.0-RELEASE

No errors are generated in ~/.local/share/qtile/qtile.log when I try to start qtile with "exec qtile start" in my .xinitrc.

I used the default make configuration of the port and its dependencies.

Any help appreciated :)
Comment 1 b1ru 2021-09-25 19:08:50 UTC
Qtile version: 0.18.1
Also tried with version 0.17 (used pkg)
Comment 2 Eric Turgeon freebsd_committer 2021-09-29 14:33:15 UTC
Starting it with lightdm works for me.