Bug 258740 - math/rumur: Fails to link: ld: error: undefined hidden symbol: rumur::* but library contains those symbols
Summary: math/rumur: Fails to link: ld: error: undefined hidden symbol: rumur::* but l...
Status: Closed Works As Intended
Alias: None
Product: Base System
Classification: Unclassified
Component: misc (show other bugs)
Version: 13.0-STABLE
Hardware: Any Any
: --- Affects Only Me
Assignee: freebsd-toolchain (Nobody)
URL:
Keywords: needs-qa
Depends on:
Blocks:
 
Reported: 2021-09-27 05:28 UTC by Yuri Victorovich
Modified: 2021-09-27 16:19 UTC (History)
1 user (show)

See Also:


Attachments
rumur-2021.08.28.log.xz (3.39 KB, application/x-xz)
2021-09-27 07:36 UTC, Yuri Victorovich
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Yuri Victorovich freebsd_committer 2021-09-27 05:28:39 UTC
I am trying to update the port math/rumur to 2021.08.28:
1. Change VERSION in /usr/ports/math/rumur/Makefile to 2021.08.28
2. make makesum
3. make

This fails with:
> ld: error: undefined hidden symbol: rumur::parse(std::__1::basic_istream<char, std::__1::char_traits<char> >&)
> >>> referenced by main.cc
> >>>               murphi2murphi/CMakeFiles/murphi2murphi.dir/src/main.cc.o:(main)
> 
> ld: error: undefined hidden symbol: rumur::resolve_symbols(rumur::Model&)
> >>> referenced by main.cc
> >>>               murphi2murphi/CMakeFiles/murphi2murphi.dir/src/main.cc.o:(main)
> 
> ld: error: undefined hidden symbol: rumur::validate(rumur::Node const&)
> >>> referenced by main.cc
> >>>               murphi2murphi/CMakeFiles/murphi2murphi.dir/src/main.cc.o:(main)
> c++: error: linker command failed with exit code 1 (use -v to see invocation)

The 'resolve_symbols' symbol is in the library:
> $ nm work/.build/librumur/librumur.so | grep resolve_symbols | c++filt
> 0000000000079b70 T rumur::resolve_symbols(rumur::Model&)

It's unclear what do error messages mean.
Comment 1 Kubilay Kocak freebsd_committer freebsd_triage 2021-09-27 07:07:55 UTC
Can you attach a full build log, compressed if necessary, please Yuri
Comment 2 Yuri Victorovich freebsd_committer 2021-09-27 07:36:06 UTC
Created attachment 228207 [details]
rumur-2021.08.28.log.xz

Attaching the build log.
Comment 3 Yuri Victorovich freebsd_committer 2021-09-27 16:19:20 UTC
This is likely due to a bug in the project.