Bug 258759 - committers-guide: Remove 'use-agent' from minimum gpg.conf settings
Summary: committers-guide: Remove 'use-agent' from minimum gpg.conf settings
Status: Closed FIXED
Alias: None
Product: Documentation
Classification: Unclassified
Component: Documentation (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Yasuhiro Kimura
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-09-28 09:56 UTC by Yasuhiro Kimura
Modified: 2021-09-29 07:55 UTC (History)
2 users (show)

See Also:


Attachments
Patch file (1.43 KB, patch)
2021-09-28 09:56 UTC, Yasuhiro Kimura
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Yasuhiro Kimura freebsd_committer 2021-09-28 09:56:53 UTC
Created attachment 228229 [details]
Patch file

In the gpg2(1) man page 'use-agent' option is explained as following.

----------------------------------------------------------------------
       --use-agent
       --no-use-agent
              This is dummy option. gpg2 always requires the agent.
----------------------------------------------------------------------

It means adding 'use-agent' to gpg.conf is no-op. So remove it from
minimum acceptable defaults of gpg.conf.
Comment 1 Danilo G. Baio freebsd_committer 2021-09-28 22:32:01 UTC
Thanks for reporting it, makes sense.

Assigning this ticket to you as you are a committer now. =)

Please, open a review for your mentors, ygy has a doc bit and can also approve this.

If meta is the reviewer, you can add it was approved by dbaio (doc).

Regards.
Comment 2 Guangyuan Yang freebsd_committer 2021-09-28 22:47:10 UTC
Approved, please feel free to commit this. Thank you!
Comment 3 Yasuhiro Kimura freebsd_committer 2021-09-29 07:55:32 UTC
Oops, I forgot to add "PR: 258759" to commit message.
Committed as doc 183cc245fa.