Bug 258770 - security/sudo 1.9.8 breaks Ansible, option passprompt_override does not take a value
Summary: security/sudo 1.9.8 breaks Ansible, option passprompt_override does not take ...
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Many People
Assignee: Renato Botelho
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-09-28 22:17 UTC by Miroslav Lachman
Modified: 2021-09-30 13:33 UTC (History)
1 user (show)

See Also:
bugzilla: maintainer-feedback? (garga)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Miroslav Lachman 2021-09-28 22:17:16 UTC
After pkg upgrade sudo to version 1.9.8 the regression was introduced and Ansible (and some othr usages) ar no longer able to work with sudo.

The error message is:

module_stdout: sudo: (null): option passprompt_override does not take a value
sudo: error initializing audit plugin sudoers_audit

It is reported on other platforms too:

https://github.com/ansible/ansible/issues/75718

The fixing patch is here:
https://github.com/archlinux/svntogit-packages/commit/fb4cc13d0f4d1db3720865d060a9d6623fd128f7#diff-3e341d2d9c67be01819b25b25d5e53ea3cdf3a38d28846cda85a195eb9b7203a

Can this fix be applied to FreeBSD port and backported to quarterly too? Current quarterly sudo + ansible is broken.
Comment 1 wolfgang 2021-09-30 12:16:22 UTC
That bug appears to have been fixed in HEAD but not in the 2021Q3 branch that we use in production. Even with today being the last day of Q3, this problem is big enough that it warrants a last day update in the quarterly branch, IMO.
Comment 2 Renato Botelho freebsd_committer 2021-09-30 12:24:54 UTC
(In reply to wolfgang from comment #1)
1.9.8p1 is now merged into 2021Q3 branch.  Please let me know if it fixes the problem.
Comment 3 Miroslav Lachman 2021-09-30 13:13:38 UTC
(In reply to Renato Botelho from comment #2)
Cannot say if p1 fixed it, it was too urgent to wait that we already build 1.9.8p2 in our poudriere and installed it on all machines. sudo-1.9.8p2 fixed it.
Comment 4 wolfgang 2021-09-30 13:24:26 UTC
I can confirm that 1.9.8p1 fixes the problem for me.