Bug 258847 - sysutils/lnav: Update to 0.10.1
Summary: sysutils/lnav: Update to 0.10.1
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Neel Chauhan
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-10-01 15:34 UTC by Thomas Hurst
Modified: 2021-10-29 16:44 UTC (History)
1 user (show)

See Also:


Attachments
Patch to 0.10.0 (2.79 KB, patch)
2021-10-01 15:34 UTC, Thomas Hurst
no flags Details | Diff
Patch to 0.10.1 (2.53 KB, patch)
2021-10-29 02:00 UTC, Thomas Hurst
tom: maintainer-approval+
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Thomas Hurst 2021-10-01 15:34:36 UTC
Created attachment 228327 [details]
Patch to 0.10.0

Update to 0.10.0, and mark BROKEN on i386 due to 64-bit time_t assumptions.

Notable changes include accessing logs from remotes via SSH, and transparent
support for compressed and archived logs via libarchive.

Release notes: https://github.com/tstack/lnav/releases/tag/v0.10.0
Comment 1 Thomas Hurst 2021-10-05 02:03:16 UTC
0.10.1 should be available soon fixing a few regressions and the 32-bit build.
Comment 2 Thomas Hurst 2021-10-29 02:00:03 UTC
Created attachment 229113 [details]
Patch to 0.10.1
Comment 3 Neel Chauhan freebsd_committer 2021-10-29 16:42:44 UTC
Committed!
Comment 4 commit-hook freebsd_committer 2021-10-29 16:44:50 UTC
A commit in branch main references this bug:

URL: https://cgit.FreeBSD.org/ports/commit/?id=fb07233b044ee9b65d5a0b227da4d2fc0ca30697

commit fb07233b044ee9b65d5a0b227da4d2fc0ca30697
Author:     Thomas Hurst <tom@hur.st>
AuthorDate: 2021-10-29 16:40:05 +0000
Commit:     Neel Chauhan <nc@FreeBSD.org>
CommitDate: 2021-10-29 16:44:07 +0000

    sysutils/lnav: Update to 0.10.1

    PR:     258847

 sysutils/lnav/Makefile                          |  2 +-
 sysutils/lnav/distinfo                          |  6 ++--
 sysutils/lnav/files/patch-src_logfile.cc (gone) | 37 -------------------------
 3 files changed, 4 insertions(+), 41 deletions(-)