Bug 258868 - gimp plugins (PKG) not working or not appearing in menu
Summary: gimp plugins (PKG) not working or not appearing in menu
Status: New
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: amd64 Any
: --- Affects Only Me
Assignee: freebsd-ports-bugs (Nobody)
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-10-02 13:37 UTC by Michael
Modified: 2021-10-02 13:37 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Michael 2021-10-02 13:37:23 UTC
the actual gimp pkg version is 2.10.24 on Fbsd 13, kde plasma 5.22.4

gimp is basically working, but not the plugins, gmic is not even appearing in the menu, resynthesizer also not as well as other plugins for example some installed FUs are not there

I have py27 installed as default version for gimp and the py plugins should work, I know they are ok, because I have them working through the latest gimp versions since 2.10.something, only that they are linux machines

specialy I am interested in plugin-heal-selection.py because it is important for my work

eventually the point is this startup error

  File "/usr/local/libexec/gimp/2.2/plug-ins/plugin-resynth-fill-pattern.py", line 33, in <module>
    from gimpfu import *
ModuleNotFoundError: No module named 'gimpfu'

all failing plugins are claiming "No module named 'gimpfu'" but gimpfu is in the expected place, well, I guess it is

/usr/local/libexec/gimp/2.2/plug-ins/script-fu/script-fu*

I created sym links 2.0 and 2.1 to 2.2 because no effect

I hope you can help me here

thanks