Bug 258969 - deskutils/nextcloudclient: login fails the second time
Summary: deskutils/nextcloudclient: login fails the second time
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Michael Reifenberger
URL:
Keywords:
: 258968 (view as bug list)
Depends on: 257945
Blocks:
  Show dependency treegraph
 
Reported: 2021-10-06 20:03 UTC by Jörg Preiß
Modified: 2021-10-21 21:13 UTC (History)
1 user (show)

See Also:
bugzilla: maintainer-feedback? (mr)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jörg Preiß 2021-10-06 20:03:33 UTC
The client does not get the login event (after a reboot?). The client starts, opens the browser window, gets the login event, and directly reports 'You have been logged out. Reopen browser'. Same for the second try. I tried Chrome and Firefox w/o success. As I tried FF for the first time, it shouldn't have to do something with the browser cache.
Comment 1 Jörg Preiß 2021-10-06 20:04:27 UTC
*** Bug 258968 has been marked as a duplicate of this bug. ***
Comment 2 Guido Falsi freebsd_committer 2021-10-06 21:47:01 UTC
Please see bug #257945 which contains an update reported to solve the issue.
Comment 3 Guido Falsi freebsd_committer 2021-10-17 19:56:32 UTC
The update in bug #257945 has been committed to the tree and also merged to quarterly.

Can you test again and close this bug report if the issue is fixed?

Thanks!
Comment 4 Jörg Preiß 2021-10-18 13:19:33 UTC
I've removed the cookies.db from the config folder - just to be sure -, but the behaviour is still the same. 
I've built the update via portmaster -D deskutils/nextcloudclient.

```
Git revision 50453d9d7e5b42749b86e7a7f0e6b61b69b79650
Using Qt 5.15.2, built against Qt 5.15.2
Using Qt platform plugin 'xcb'
Using 'OpenSSL 1.1.1l-freebsd  24 Aug 2021'
Running on FreeBSD 14.0-CURRENT, x86_64
```

Am I doing something wrong?
Comment 5 Guido Falsi freebsd_committer 2021-10-18 15:40:30 UTC
(In reply to Jörg Preiß from comment #4)

I don't know what the issue is. I've always configured nextcloudclient by manually creating the password and pasting it in the client. Never went through the browser for that.

Nor even sure how that procedure really works under the hood.

As general advice I'd suggest you check you are allowing scripts and cookies in the browser, nothing is interfering with cut&paste (just in case that's a required communication channel).

Also check the installed port version is 3.3.5 or higher. My commits only updated the client to newer upstream versions, I have not investigated the issue itself, but updates were reported to fix it.
Comment 6 Jörg Preiß 2021-10-21 21:12:59 UTC
Works now