Bug 259080 - devel/meson: update to 0.60.1
Summary: devel/meson: update to 0.60.1
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: freebsd-desktop (Team)
URL: https://mesonbuild.com/Release-notes-...
Keywords: needs-qa, patch
Depends on: 259140
Blocks:
  Show dependency treegraph
 
Reported: 2021-10-11 17:55 UTC by Jan Beich
Modified: 2021-11-29 07:53 UTC (History)
3 users (show)

See Also:
tcberner: maintainer-feedback+
antoine: exp-run+


Attachments
v0 (RC1) (2.28 KB, patch)
2021-10-11 17:55 UTC, Jan Beich
no flags Details | Diff
v0.1 (RC2) (3.27 KB, patch)
2021-10-19 15:33 UTC, Jan Beich
no flags Details | Diff
v1 (0.60.0) (3.26 KB, patch)
2021-10-24 18:51 UTC, Jan Beich
no flags Details | Diff
v2 (0.60.1) (3.26 KB, patch)
2021-11-03 09:03 UTC, Jan Beich
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Jan Beich freebsd_committer 2021-10-11 17:55:31 UTC
Created attachment 228598 [details]
v0 (RC1)
Comment 1 Jan Beich freebsd_committer 2021-10-11 17:58:39 UTC
Previous dot-zero updates often had regressions, requiring to wait for a patch-level release. Let's try testing in advance.
Comment 2 Antoine Brodin freebsd_committer 2021-10-13 12:58:56 UTC
Some new failure logs:

http://package18.nyi.freebsd.org/data/122amd64-default-foo/2021-10-12_18h01m25s/logs/errors/nautilus-sendto-3.8.6.log
http://package18.nyi.freebsd.org/data/122amd64-default-foo/2021-10-12_18h01m25s/logs/errors/kiwix-lib-9.4.1_2.log
http://package18.nyi.freebsd.org/data/122amd64-default-foo/2021-10-12_18h01m25s/logs/errors/libvirt-7.7.0.log
http://package18.nyi.freebsd.org/data/122amd64-default-foo/2021-10-12_18h01m25s/logs/errors/newt-0.52.21.log
http://package18.nyi.freebsd.org/data/122amd64-default-foo/2021-10-12_18h01m25s/logs/errors/mesa-libs-21.1.5_2.log
http://package18.nyi.freebsd.org/data/122amd64-default-foo/2021-10-12_18h01m25s/logs/errors/libmodulemd-2.13.0.log
http://package18.nyi.freebsd.org/data/122amd64-default-foo/2021-10-12_18h01m25s/logs/errors/shared-mime-info-2.0.log
http://package18.nyi.freebsd.org/data/122amd64-default-foo/2021-10-12_18h01m25s/logs/errors/urbit-0.6.0.log
http://package18.nyi.freebsd.org/data/122amd64-default-foo/2021-10-12_18h01m25s/logs/errors/libnice-gst1-0.1.18_1.log
http://package18.nyi.freebsd.org/data/122amd64-default-foo/2021-10-12_18h01m25s/logs/errors/accountsservice-0.6.55_1.log
http://package18.nyi.freebsd.org/data/122amd64-default-foo/2021-10-12_18h01m25s/logs/errors/tracker-2.3.4_3.log
http://package18.nyi.freebsd.org/data/122amd64-default-foo/2021-10-12_18h01m25s/logs/errors/tracker3-3.1.2.log
http://package18.nyi.freebsd.org/data/122amd64-default-foo/2021-10-12_18h01m25s/logs/errors/virtboard-0.0.6_1.log
Comment 3 Jan Beich freebsd_committer 2021-10-13 15:51:35 UTC
(In reply to Antoine Brodin from comment #2)
> http://package18.nyi.freebsd.org/data/122amd64-default-foo/2021-10-12_18h01m25s/logs/errors/newt-0.52.21.log
[...]
> checking for python versions... ./configure: 3839: Syntax error: ")" unexpected (expecting "fi")

A false positive? Matches existing bustage:

http://beefy16.nyi.freebsd.org/data/130amd64-default/942f6ee81c10/logs/newt-0.52.21.log
http://beefy6.nyi.freebsd.org/data/122amd64-default/942f6ee81c10/logs/newt-0.52.21.log
Comment 4 commit-hook freebsd_committer 2021-10-13 16:56:39 UTC
A commit in branch main references this bug:

URL: https://cgit.FreeBSD.org/ports/commit/?id=c2c3dc30c39fa6b433993ff7365d0b23e4becdb1

commit c2c3dc30c39fa6b433993ff7365d0b23e4becdb1
Author:     Jan Beich <jbeich@FreeBSD.org>
AuthorDate: 2021-10-13 16:16:31 +0000
Commit:     Jan Beich <jbeich@FreeBSD.org>
CommitDate: 2021-10-13 16:52:55 +0000

    sysutils/tracker3: drop unused Meson options after 2c352e0f7328

    meson.build:1:0: ERROR: Unknown options: "network_manager"

    https://gitlab.gnome.org/GNOME/tracker/-/commit/d9c80789540b

    PR:             259080
    Reported by:    antoine (via exp-run)
    Regressed by:   https://github.com/mesonbuild/meson/commit/dbf2ace6ca1c

 sysutils/tracker3/Makefile | 1 -
 1 file changed, 1 deletion(-)
Comment 5 commit-hook freebsd_committer 2021-10-13 16:56:40 UTC
A commit in branch main references this bug:

URL: https://cgit.FreeBSD.org/ports/commit/?id=81d28e312645186953adcbc7a4c08fcf27363c1b

commit 81d28e312645186953adcbc7a4c08fcf27363c1b
Author:     Jan Beich <jbeich@FreeBSD.org>
AuthorDate: 2021-10-13 15:42:43 +0000
Commit:     Jan Beich <jbeich@FreeBSD.org>
CommitDate: 2021-10-13 16:52:54 +0000

    devel/kiwix-lib: drop unused Meson options after dd6e94a4f51a

    meson.build:1:0: ERROR: Unknown options: "ctpp2-install-prefix"

    https://github.com/kiwix/libkiwix/commit/92c9a47a0d63

    PR:             259080
    Reported by:    antoine (via exp-run)
    Regressed by:   https://github.com/mesonbuild/meson/commit/dbf2ace6ca1c

 devel/kiwix-lib/Makefile | 1 -
 1 file changed, 1 deletion(-)
Comment 6 commit-hook freebsd_committer 2021-10-13 16:56:41 UTC
A commit in branch main references this bug:

URL: https://cgit.FreeBSD.org/ports/commit/?id=81cb5eaab9ef01cc32f0de0acc55d0bd1b75ac41

commit 81cb5eaab9ef01cc32f0de0acc55d0bd1b75ac41
Author:     Jan Beich <jbeich@FreeBSD.org>
AuthorDate: 2021-10-13 15:32:54 +0000
Commit:     Jan Beich <jbeich@FreeBSD.org>
CommitDate: 2021-10-13 16:52:54 +0000

    devel/libvirt: drop unused Meson options after e03306805502

    meson.build:1:0: ERROR: Unknown options: "dbus, hal"

    https://gitlab.com/libvirt/libvirt/-/commit/cf6cc86cd217
    https://gitlab.com/libvirt/libvirt/-/commit/de3289e2b538

    PR:             259080
    Reported by:    antoine (via exp-run)
    Regressed by:   https://github.com/mesonbuild/meson/commit/dbf2ace6ca1c

 devel/libvirt/Makefile | 2 --
 1 file changed, 2 deletions(-)
Comment 7 commit-hook freebsd_committer 2021-10-13 16:56:42 UTC
A commit in branch main references this bug:

URL: https://cgit.FreeBSD.org/ports/commit/?id=940784dbb799c3a52315705fb751294c47ed667b

commit 940784dbb799c3a52315705fb751294c47ed667b
Author:     Jan Beich <jbeich@FreeBSD.org>
AuthorDate: 2021-10-13 16:16:31 +0000
Commit:     Jan Beich <jbeich@FreeBSD.org>
CommitDate: 2021-10-13 16:52:55 +0000

    net-im/libnice-gst1: drop unused Meson options after 3367f62c42b8

    meson.build:1:0: ERROR: Unknown options: "gst_version"

    PR:             259080
    Reported by:    antoine (via exp-run)
    Regressed by:   https://github.com/mesonbuild/meson/commit/dbf2ace6ca1c

 net-im/libnice/Makefile | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)
Comment 8 commit-hook freebsd_committer 2021-10-13 16:56:42 UTC
A commit in branch main references this bug:

URL: https://cgit.FreeBSD.org/ports/commit/?id=a0818e6d53420034aa6139f12bb90859ea60926f

commit a0818e6d53420034aa6139f12bb90859ea60926f
Author:     Jan Beich <jbeich@FreeBSD.org>
AuthorDate: 2021-10-13 16:16:31 +0000
Commit:     Jan Beich <jbeich@FreeBSD.org>
CommitDate: 2021-10-13 16:52:54 +0000

    misc/libmodulemd: drop unused Meson options after 8e0304d612f2

    meson.build:12:0: ERROR: Unknown options: "developer_build, skip_formatters"

    https://github.com/fedora-modularity/libmodulemd/commit/1096cda67bbb

    PR:             259080
    Reported by:    antoine (via exp-run)
    Regressed by:   https://github.com/mesonbuild/meson/commit/dbf2ace6ca1c

 misc/libmodulemd/Makefile | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)
Comment 9 commit-hook freebsd_committer 2021-10-13 16:56:43 UTC
A commit in branch main references this bug:

URL: https://cgit.FreeBSD.org/ports/commit/?id=e36765b80173f629fa90246809e0b0e363f77bde

commit e36765b80173f629fa90246809e0b0e363f77bde
Author:     Jan Beich <jbeich@FreeBSD.org>
AuthorDate: 2021-10-13 16:16:31 +0000
Commit:     Jan Beich <jbeich@FreeBSD.org>
CommitDate: 2021-10-13 16:52:55 +0000

    sysutils/tracker: drop unused Meson options after 2c352e0f7328

    meson.build:1:0: ERROR: Unknown options: "bash_completion_dir"

    https://gitlab.gnome.org/GNOME/tracker/-/commit/d318ebeb5d4f
    is missing in 2.3.4 unlike 3.1.2 used by sysutils/tracker3.

    PR:             259080
    Reported by:    antoine (via exp-run)
    Regressed by:   https://github.com/mesonbuild/meson/commit/dbf2ace6ca1c

 sysutils/tracker/Makefile | 1 -
 1 file changed, 1 deletion(-)
Comment 10 Jan Beich freebsd_committer 2021-10-19 15:33:17 UTC
Created attachment 228840 [details]
v0.1 (RC2)

Antoine, can you try again? I need a fresh picture what still fails and what was previously hidden by broken dependencies.

Changes since v0 (RC1):
- Update to RC2
- Add shared-mime-info workaround to unblock 1882 ports
Comment 11 Antoine Brodin freebsd_committer 2021-10-22 13:24:39 UTC
Some new failure logs:

http://package22.nyi.freebsd.org/data/130amd64-default-foo/2021-10-19_17h57m43s/logs/errors/gnome-podcasts-0.4.9_2.log
http://package22.nyi.freebsd.org/data/130amd64-default-foo/2021-10-19_17h57m43s/logs/errors/gnome-calendar-41.0.log
http://package22.nyi.freebsd.org/data/130amd64-default-foo/2021-10-19_17h57m43s/logs/errors/gnome-characters-41.0.log
http://package22.nyi.freebsd.org/data/130amd64-default-foo/2021-10-19_17h57m43s/logs/errors/gnome-dictionary-40.0.log
http://package22.nyi.freebsd.org/data/130amd64-default-foo/2021-10-19_17h57m43s/logs/errors/gnome-font-viewer-41.0.log
http://package22.nyi.freebsd.org/data/130amd64-default-foo/2021-10-19_17h57m43s/logs/errors/gnome-photos-40.0.log
http://package22.nyi.freebsd.org/data/130amd64-default-foo/2021-10-19_17h57m43s/logs/errors/gnome-screenshot-40.0.log
http://package22.nyi.freebsd.org/data/130amd64-default-foo/2021-10-19_17h57m43s/logs/errors/gnome-sound-recorder-40.0.log
http://package22.nyi.freebsd.org/data/130amd64-default-foo/2021-10-19_17h57m43s/logs/errors/gnome-weather-41.0.log
http://package22.nyi.freebsd.org/data/130amd64-default-foo/2021-10-19_17h57m43s/logs/errors/gnote-41.0.log
http://package22.nyi.freebsd.org/data/130amd64-default-foo/2021-10-19_17h57m43s/logs/errors/gucharmap-13.0.8.log
http://package22.nyi.freebsd.org/data/130amd64-default-foo/2021-10-19_17h57m43s/logs/errors/nautilus-sendto-3.8.6.log
http://package22.nyi.freebsd.org/data/130amd64-default-foo/2021-10-19_17h57m43s/logs/errors/solanum-2.1.0_3.log
http://package22.nyi.freebsd.org/data/130amd64-default-foo/2021-10-19_17h57m43s/logs/errors/d-feet-0.3.15.log
http://package22.nyi.freebsd.org/data/130amd64-default-foo/2021-10-19_17h57m43s/logs/errors/dconf-editor-3.38.3.log
http://package22.nyi.freebsd.org/data/130amd64-default-foo/2021-10-19_17h57m43s/logs/errors/devhelp-41.2.log
http://package22.nyi.freebsd.org/data/130amd64-default-foo/2021-10-19_17h57m43s/logs/errors/gitg-3.32.1_3.log
http://package22.nyi.freebsd.org/data/130amd64-default-foo/2021-10-19_17h57m43s/logs/errors/gtranslator-40.0.log
http://package22.nyi.freebsd.org/data/130amd64-default-foo/2021-10-19_17h57m43s/logs/errors/libvirt-7.7.0.log
http://package22.nyi.freebsd.org/data/130amd64-default-foo/2021-10-19_17h57m43s/logs/errors/msitools-0.101.log
http://package22.nyi.freebsd.org/data/130amd64-default-foo/2021-10-19_17h57m43s/logs/errors/py38-pyside2-5.15.2_2.log
http://package22.nyi.freebsd.org/data/130amd64-default-foo/2021-10-19_17h57m43s/logs/errors/elementary-code-6.0.0.log
http://package22.nyi.freebsd.org/data/130amd64-default-foo/2021-10-19_17h57m43s/logs/errors/gedit-40.1.log
http://package22.nyi.freebsd.org/data/130amd64-default-foo/2021-10-19_17h57m43s/logs/errors/aisleriot-3.22.18.log
http://package22.nyi.freebsd.org/data/130amd64-default-foo/2021-10-19_17h57m43s/logs/errors/gnome-2048-3.38.2_1.log
http://package22.nyi.freebsd.org/data/130amd64-default-foo/2021-10-19_17h57m43s/logs/errors/gnome-mahjongg-3.38.3.log
http://package22.nyi.freebsd.org/data/130amd64-default-foo/2021-10-19_17h57m43s/logs/errors/gnome-mines-40.0.log
http://package22.nyi.freebsd.org/data/130amd64-default-foo/2021-10-19_17h57m43s/logs/errors/gnome-sudoku-40.2.log
http://package22.nyi.freebsd.org/data/130amd64-default-foo/2021-10-19_17h57m43s/logs/errors/gnome-tetravex-3.38.2.log
http://package22.nyi.freebsd.org/data/130amd64-default-foo/2021-10-19_17h57m43s/logs/errors/hitori-3.38.3.log
http://package22.nyi.freebsd.org/data/130amd64-default-foo/2021-10-19_17h57m43s/logs/errors/taisei-1.3.2.log
http://package22.nyi.freebsd.org/data/130amd64-default-foo/2021-10-19_17h57m43s/logs/errors/tali-40.3.log
http://package22.nyi.freebsd.org/data/130amd64-default-foo/2021-10-19_17h57m43s/logs/errors/entangle-1.0.log
http://package22.nyi.freebsd.org/data/130amd64-default-foo/2021-10-19_17h57m43s/logs/errors/eog-41.0.log
http://package22.nyi.freebsd.org/data/130amd64-default-foo/2021-10-19_17h57m43s/logs/errors/evince-lite-40.4_3.log
http://package22.nyi.freebsd.org/data/130amd64-default-foo/2021-10-19_17h57m43s/logs/errors/frogr-1.6.log
http://package22.nyi.freebsd.org/data/130amd64-default-foo/2021-10-19_17h57m43s/logs/errors/gnome-color-manager-3.36.0.log
http://package22.nyi.freebsd.org/data/130amd64-default-foo/2021-10-19_17h57m43s/logs/errors/polari-41.0.log
http://package22.nyi.freebsd.org/data/130amd64-default-foo/2021-10-19_17h57m43s/logs/errors/pantheon-calculator-1.7.0.log
http://package22.nyi.freebsd.org/data/130amd64-default-foo/2021-10-19_17h57m43s/logs/errors/urbit-0.6.0.log
http://package22.nyi.freebsd.org/data/130amd64-default-foo/2021-10-19_17h57m43s/logs/errors/cheese-41.0.log
http://package22.nyi.freebsd.org/data/130amd64-default-foo/2021-10-19_17h57m43s/logs/errors/elementary-videos-2.7.3.log
http://package22.nyi.freebsd.org/data/130amd64-default-foo/2021-10-19_17h57m43s/logs/errors/handbrake-1.4.2_1.log
http://package22.nyi.freebsd.org/data/130amd64-default-foo/2021-10-19_17h57m43s/logs/errors/fractal-4.4.0.log
http://package22.nyi.freebsd.org/data/130amd64-default-foo/2021-10-19_17h57m43s/logs/errors/dpdk20.11-20.11.1.log
http://package22.nyi.freebsd.org/data/130amd64-default-foo/2021-10-19_17h57m43s/logs/errors/xreader-3.0.2_4.log
http://package22.nyi.freebsd.org/data/130amd64-default-foo/2021-10-19_17h57m43s/logs/errors/authenticator-4.0.3_3.log
http://package22.nyi.freebsd.org/data/130amd64-default-foo/2021-10-19_17h57m43s/logs/errors/accountsservice-0.6.55_1.log
http://package22.nyi.freebsd.org/data/130amd64-default-foo/2021-10-19_17h57m43s/logs/errors/gnome-settings-daemon-3.38.2.log
http://package22.nyi.freebsd.org/data/130amd64-default-foo/2021-10-19_17h57m43s/logs/errors/tracker-2.3.4_4.log
http://package22.nyi.freebsd.org/data/130amd64-default-foo/2021-10-19_17h57m43s/logs/errors/epiphany-41.0.log
http://package22.nyi.freebsd.org/data/130amd64-default-foo/2021-10-19_17h57m43s/logs/errors/nemo-4.8.3_1.log
http://package22.nyi.freebsd.org/data/130amd64-default-foo/2021-10-19_17h57m43s/logs/errors/girara-0.3.6.log
http://package22.nyi.freebsd.org/data/130amd64-default-foo/2021-10-19_17h57m43s/logs/errors/enlightenment-0.24.2,2.log
http://package22.nyi.freebsd.org/data/130amd64-default-foo/2021-10-19_17h57m43s/logs/errors/appmenu-registrar-0.7.6.log
http://package22.nyi.freebsd.org/data/130amd64-default-foo/2021-10-19_17h57m43s/logs/errors/elementary-terminal-6.0.0.log
http://package22.nyi.freebsd.org/data/130amd64-default-foo/2021-10-19_17h57m43s/logs/errors/gnome-session-40.1.1.log
http://package22.nyi.freebsd.org/data/130amd64-default-foo/2021-10-19_17h57m43s/logs/errors/squeekboard-1.14.0_3.log
http://package22.nyi.freebsd.org/data/130amd64-default-foo/2021-10-19_17h57m43s/logs/errors/virtboard-0.0.6_1.log
Comment 12 Jan Beich freebsd_committer 2021-10-24 18:51:15 UTC
Created attachment 229000 [details]
v1 (0.60.0)

Now released. Unlikely to help with the fallout in comment 11.
https://github.com/mesonbuild/meson/compare/0.60.0rc2...0.60.0
Comment 13 Antoine Brodin freebsd_committer 2021-10-28 17:32:40 UTC
The failures look similar:


http://package22.nyi.freebsd.org/data/130amd64-default-foo/2021-10-27_18h08m56s/logs/gnome-podcasts-0.4.9_3.log
http://package22.nyi.freebsd.org/data/130amd64-default-foo/2021-10-27_18h08m56s/logs/gnome-calendar-41.0.log
http://package22.nyi.freebsd.org/data/130amd64-default-foo/2021-10-27_18h08m56s/logs/gnome-characters-41.0.log
http://package22.nyi.freebsd.org/data/130amd64-default-foo/2021-10-27_18h08m56s/logs/gnome-dictionary-40.0.log
http://package22.nyi.freebsd.org/data/130amd64-default-foo/2021-10-27_18h08m56s/logs/gnome-font-viewer-41.0.log
http://package22.nyi.freebsd.org/data/130amd64-default-foo/2021-10-27_18h08m56s/logs/gnome-photos-40.0.log
http://package22.nyi.freebsd.org/data/130amd64-default-foo/2021-10-27_18h08m56s/logs/gnome-screenshot-40.0.log
http://package22.nyi.freebsd.org/data/130amd64-default-foo/2021-10-27_18h08m56s/logs/gnome-sound-recorder-40.0.log
http://package22.nyi.freebsd.org/data/130amd64-default-foo/2021-10-27_18h08m56s/logs/gnome-weather-41.0.log
http://package22.nyi.freebsd.org/data/130amd64-default-foo/2021-10-27_18h08m56s/logs/gnote-41.0.log
http://package22.nyi.freebsd.org/data/130amd64-default-foo/2021-10-27_18h08m56s/logs/gucharmap-13.0.8.log
http://package22.nyi.freebsd.org/data/130amd64-default-foo/2021-10-27_18h08m56s/logs/nautilus-sendto-3.8.6.log
http://package22.nyi.freebsd.org/data/130amd64-default-foo/2021-10-27_18h08m56s/logs/solanum-2.1.0_4.log
http://package22.nyi.freebsd.org/data/130amd64-default-foo/2021-10-27_18h08m56s/logs/d-feet-0.3.15.log
http://package22.nyi.freebsd.org/data/130amd64-default-foo/2021-10-27_18h08m56s/logs/dconf-editor-3.38.3.log
http://package22.nyi.freebsd.org/data/130amd64-default-foo/2021-10-27_18h08m56s/logs/devhelp-41.2.log
http://package22.nyi.freebsd.org/data/130amd64-default-foo/2021-10-27_18h08m56s/logs/gitg-3.32.1_3.log
http://package22.nyi.freebsd.org/data/130amd64-default-foo/2021-10-27_18h08m56s/logs/gtranslator-40.0.log
http://package22.nyi.freebsd.org/data/130amd64-default-foo/2021-10-27_18h08m56s/logs/libvirt-7.7.0.log
http://package22.nyi.freebsd.org/data/130amd64-default-foo/2021-10-27_18h08m56s/logs/msitools-0.101.log
http://package22.nyi.freebsd.org/data/130amd64-default-foo/2021-10-27_18h08m56s/logs/elementary-code-6.0.0.log
http://package22.nyi.freebsd.org/data/130amd64-default-foo/2021-10-27_18h08m56s/logs/gedit-40.1.log
http://package22.nyi.freebsd.org/data/130amd64-default-foo/2021-10-27_18h08m56s/logs/aisleriot-3.22.18.log
http://package22.nyi.freebsd.org/data/130amd64-default-foo/2021-10-27_18h08m56s/logs/gnome-2048-3.38.2_1.log
http://package22.nyi.freebsd.org/data/130amd64-default-foo/2021-10-27_18h08m56s/logs/gnome-mahjongg-3.38.3.log
http://package22.nyi.freebsd.org/data/130amd64-default-foo/2021-10-27_18h08m56s/logs/gnome-mines-40.0.log
http://package22.nyi.freebsd.org/data/130amd64-default-foo/2021-10-27_18h08m56s/logs/gnome-sudoku-40.2.log
http://package22.nyi.freebsd.org/data/130amd64-default-foo/2021-10-27_18h08m56s/logs/gnome-tetravex-3.38.2.log
http://package22.nyi.freebsd.org/data/130amd64-default-foo/2021-10-27_18h08m56s/logs/hitori-3.38.3.log
http://package22.nyi.freebsd.org/data/130amd64-default-foo/2021-10-27_18h08m56s/logs/taisei-1.3.2.log
http://package22.nyi.freebsd.org/data/130amd64-default-foo/2021-10-27_18h08m56s/logs/tali-40.3.log
http://package22.nyi.freebsd.org/data/130amd64-default-foo/2021-10-27_18h08m56s/logs/entangle-1.0.log
http://package22.nyi.freebsd.org/data/130amd64-default-foo/2021-10-27_18h08m56s/logs/eog-41.0.log
http://package22.nyi.freebsd.org/data/130amd64-default-foo/2021-10-27_18h08m56s/logs/evince-lite-40.4_3.log
http://package22.nyi.freebsd.org/data/130amd64-default-foo/2021-10-27_18h08m56s/logs/frogr-1.6.log
http://package22.nyi.freebsd.org/data/130amd64-default-foo/2021-10-27_18h08m56s/logs/gnome-color-manager-3.36.0.log
http://package22.nyi.freebsd.org/data/130amd64-default-foo/2021-10-27_18h08m56s/logs/polari-41.0.log
http://package22.nyi.freebsd.org/data/130amd64-default-foo/2021-10-27_18h08m56s/logs/pantheon-calculator-1.7.0.log
http://package22.nyi.freebsd.org/data/130amd64-default-foo/2021-10-27_18h08m56s/logs/urbit-0.6.0.log
http://package22.nyi.freebsd.org/data/130amd64-default-foo/2021-10-27_18h08m56s/logs/cheese-41.0.log
http://package22.nyi.freebsd.org/data/130amd64-default-foo/2021-10-27_18h08m56s/logs/elementary-videos-2.7.3.log
http://package22.nyi.freebsd.org/data/130amd64-default-foo/2021-10-27_18h08m56s/logs/handbrake-1.4.2_1.log
http://package22.nyi.freebsd.org/data/130amd64-default-foo/2021-10-27_18h08m56s/logs/fractal-4.4.0_1.log
http://package22.nyi.freebsd.org/data/130amd64-default-foo/2021-10-27_18h08m56s/logs/xreader-3.0.2_4.log
http://package22.nyi.freebsd.org/data/130amd64-default-foo/2021-10-27_18h08m56s/logs/authenticator-4.0.3_4.log
http://package22.nyi.freebsd.org/data/130amd64-default-foo/2021-10-27_18h08m56s/logs/accountsservice-0.6.55_1.log
http://package22.nyi.freebsd.org/data/130amd64-default-foo/2021-10-27_18h08m56s/logs/gnome-settings-daemon-3.38.2.log
http://package22.nyi.freebsd.org/data/130amd64-default-foo/2021-10-27_18h08m56s/logs/tracker-2.3.4_4.log
http://package22.nyi.freebsd.org/data/130amd64-default-foo/2021-10-27_18h08m56s/logs/epiphany-41.0.log
http://package22.nyi.freebsd.org/data/130amd64-default-foo/2021-10-27_18h08m56s/logs/nemo-4.8.3_1.log
http://package22.nyi.freebsd.org/data/130amd64-default-foo/2021-10-27_18h08m56s/logs/girara-0.3.6.log
http://package22.nyi.freebsd.org/data/130amd64-default-foo/2021-10-27_18h08m56s/logs/enlightenment-0.24.2,2.log
http://package22.nyi.freebsd.org/data/130amd64-default-foo/2021-10-27_18h08m56s/logs/appmenu-registrar-0.7.6.log
http://package22.nyi.freebsd.org/data/130amd64-default-foo/2021-10-27_18h08m56s/logs/elementary-terminal-6.0.0.log
http://package22.nyi.freebsd.org/data/130amd64-default-foo/2021-10-27_18h08m56s/logs/gnome-session-40.1.1.log
http://package22.nyi.freebsd.org/data/130amd64-default-foo/2021-10-27_18h08m56s/logs/squeekboard-1.14.0_4.log
http://package22.nyi.freebsd.org/data/130amd64-default-foo/2021-10-27_18h08m56s/logs/virtboard-0.0.6_1.log
Comment 14 commit-hook freebsd_committer 2021-11-03 09:02:27 UTC
A commit in branch main references this bug:

URL: https://cgit.FreeBSD.org/ports/commit/?id=6b44a02a1d273e145cdc4c332d2c66252312f297

commit 6b44a02a1d273e145cdc4c332d2c66252312f297
Author:     Jan Beich <jbeich@FreeBSD.org>
AuthorDate: 2021-11-03 08:57:48 +0000
Commit:     Jan Beich <jbeich@FreeBSD.org>
CommitDate: 2021-11-03 09:00:13 +0000

    print/xreader: drop unused Meson options after b8fb83c300a8

    meson.build:1:0: ERROR: Unknown options: "tests"

    https://github.com/linuxmint/xreader/commit/d39327d5a7c3

    PR:             259080
    Reported by:    antoine (via exp-run)
    Regressed by:   https://github.com/mesonbuild/meson/commit/dbf2ace6ca1c

 print/xreader/Makefile | 1 -
 1 file changed, 1 deletion(-)
Comment 15 commit-hook freebsd_committer 2021-11-03 09:02:28 UTC
A commit in branch main references this bug:

URL: https://cgit.FreeBSD.org/ports/commit/?id=5e91225d657b464d82f6c1149821086e1170fd2e

commit 5e91225d657b464d82f6c1149821086e1170fd2e
Author:     Jan Beich <jbeich@FreeBSD.org>
AuthorDate: 2021-11-03 08:48:40 +0000
Commit:     Jan Beich <jbeich@FreeBSD.org>
CommitDate: 2021-11-03 09:00:12 +0000

    graphics/gnome-color-manager: drop unused Meson options after 9ff5ddc73c00

    meson.build:1:0: ERROR: Unknown options: "exiv, packagekit"

    https://gitlab.gnome.org/GNOME/gnome-color-manager/-/commit/5a1bf35e30ff

    PR:             259080
    Reported by:    antoine (via exp-run)
    Regressed by:   https://github.com/mesonbuild/meson/commit/dbf2ace6ca1c

 graphics/gnome-color-manager/Makefile | 12 ++----------
 1 file changed, 2 insertions(+), 10 deletions(-)
Comment 16 commit-hook freebsd_committer 2021-11-03 09:02:29 UTC
A commit in branch main references this bug:

URL: https://cgit.FreeBSD.org/ports/commit/?id=0e99e1d911a18a58d5b660ea0a2c2dfc0cca91de

commit 0e99e1d911a18a58d5b660ea0a2c2dfc0cca91de
Author:     Jan Beich <jbeich@FreeBSD.org>
AuthorDate: 2021-11-03 08:54:25 +0000
Commit:     Jan Beich <jbeich@FreeBSD.org>
CommitDate: 2021-11-03 09:00:13 +0000

    games/taisei: drop unused Meson options after b5aa1e879ce9

    meson.build:1:0: ERROR: Unknown options: "OPENSSLINC"

    PR:             259080
    Reported by:    antoine (via exp-run)
    Regressed by:   https://github.com/mesonbuild/meson/commit/dbf2ace6ca1c

 games/taisei/Makefile | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)
Comment 17 commit-hook freebsd_committer 2021-11-03 09:02:29 UTC
A commit in branch main references this bug:

URL: https://cgit.FreeBSD.org/ports/commit/?id=83b2b89fdf58eb40c2efa566b2b668bb5ab8dc3f

commit 83b2b89fdf58eb40c2efa566b2b668bb5ab8dc3f
Author:     Jan Beich <jbeich@FreeBSD.org>
AuthorDate: 2021-11-03 08:21:30 +0000
Commit:     Jan Beich <jbeich@FreeBSD.org>
CommitDate: 2021-11-03 09:00:11 +0000

    graphics/frogr: fix typo in Meson option name

    meson.build:1:0: ERROR: Unknown options: "warnlevel"

    https://gitlab.gnome.org/GNOME/frogr/-/commit/623d7e397baf

    PR:             259080
    Reported by:    antoine (via exp-run)
    Regressed by:   https://github.com/mesonbuild/meson/commit/dbf2ace6ca1c

    frogr

 graphics/frogr/files/patch-meson.build | 6 ++++--
 1 file changed, 4 insertions(+), 2 deletions(-)
Comment 18 commit-hook freebsd_committer 2021-11-03 09:02:30 UTC
A commit in branch main references this bug:

URL: https://cgit.FreeBSD.org/ports/commit/?id=3168fd53e41110f005c06f89fc9f10b869b54fc4

commit 3168fd53e41110f005c06f89fc9f10b869b54fc4
Author:     Jan Beich <jbeich@FreeBSD.org>
AuthorDate: 2021-11-03 08:32:38 +0000
Commit:     Jan Beich <jbeich@FreeBSD.org>
CommitDate: 2021-11-03 09:00:12 +0000

    www/epiphany: drop unused Meson options after 6106add6f4e9

    meson.build:1:0: ERROR: Unknown options: "distributor_name"

    https://gitlab.gnome.org/GNOME/epiphany/-/commit/554a375e8a90

    PR:             259080
    Reported by:    antoine (via exp-run)
    Regressed by:   https://github.com/mesonbuild/meson/commit/dbf2ace6ca1c

 www/epiphany/Makefile | 1 -
 1 file changed, 1 deletion(-)
Comment 19 commit-hook freebsd_committer 2021-11-03 09:02:31 UTC
A commit in branch main references this bug:

URL: https://cgit.FreeBSD.org/ports/commit/?id=9a19d0e657a86a0a29624732849f4a91af87392d

commit 9a19d0e657a86a0a29624732849f4a91af87392d
Author:     Jan Beich <jbeich@FreeBSD.org>
AuthorDate: 2021-11-03 08:37:09 +0000
Commit:     Jan Beich <jbeich@FreeBSD.org>
CommitDate: 2021-11-03 09:00:12 +0000

    x11-toolkits/girara: chase Meson option name after 7ab84affb07f

    meson.build:1:0: ERROR: Unknown options: "enable-json, enable-notify"

    https://git.pwmt.org/pwmt/girara/-/commit/281011a18772

    PR:             259080
    Reported by:    antoine (via exp-run)
    Regressed by:   https://github.com/mesonbuild/meson/commit/dbf2ace6ca1c

 x11-toolkits/girara/Makefile | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)
Comment 20 Jan Beich freebsd_committer 2021-11-03 09:03:23 UTC
Created attachment 229236 [details]
v2 (0.60.1)

https://github.com/mesonbuild/meson/compare/0.60.0...0.60.1

I need another exp-run. 0.60.1 fixes at least the following:
- audio/gnome-podcasts: ERROR: Function does not take positional arguments.
- deskutils/gnome-calendar: ERROR: Function does not take positional arguments.
- deskutils/gnome-characters: ERROR: Function does not take positional arguments.
- deskutils/gnome-dictionary: ERROR: Function does not take positional arguments.
- deskutils/gnome-font-viewer: ERROR: Function does not take positional arguments.
- deskutils/gnome-photos: ERROR: Function does not take positional arguments.
- deskutils/gnome-screenshot: ERROR: Function does not take positional arguments.
- deskutils/gnome-sound-recorder: ERROR: Function does not take positional arguments.
- deskutils/gnome-weather: ERROR: Function does not take positional arguments.
- deskutils/gnote: ERROR: Function does not take positional arguments.
- deskutils/gucharmap: ERROR: Function does not take positional arguments.
- deskutils/nautilus-sendto: ERROR: Function does not take positional arguments.
- deskutils/solanum: ERROR: Function does not take positional arguments.
- devel/d-feet: ERROR: Function does not take positional arguments.
- devel/dconf-editor: ERROR: Function does not take positional arguments.
- devel/devhelp: ERROR: Function does not take positional arguments.
- devel/gitg: ERROR: Function does not take positional arguments.
- devel/gtranslator: ERROR: Function does not take positional arguments.
- devel/msitools: KeyError: 'install_dir'
- editors/elementary-code: ERROR: Function does not take positional arguments.
- editors/gedit: ERROR: Function does not take positional arguments.
- games/aisleriot: ERROR: Function does not take positional arguments.
- games/gnome-2048: ERROR: Function does not take positional arguments.
- games/gnome-mahjongg: ERROR: Function does not take positional arguments.
- games/gnome-mines: ERROR: Function does not take positional arguments.
- games/gnome-sudoku: ERROR: Function does not take positional arguments.
- games/gnome-tetravex: ERROR: Function does not take positional arguments.
- games/hitori: ERROR: Function does not take positional arguments.
- games/tali: ERROR: Function does not take positional arguments.
- graphics/entangle: ERROR: Function does not take positional arguments.
- graphics/eog: ERROR: Function does not take positional arguments.
- graphics/evince: ERROR: Function does not take positional arguments.
- irc/polari: ERROR: Function does not take positional arguments.
- math/pantheon-calculator: ERROR: Function does not take positional arguments.
- multimedia/cheese: ERROR: Function does not take positional arguments.
- multimedia/elementary-videos: ERROR: Function does not take positional arguments.
- net-im/fractal: ERROR: Function does not take positional arguments.
- security/authenticator: ERROR: Function does not take positional arguments.
- sysutils/accountsservice: ERROR: Function does not take positional arguments.
- sysutils/tracker: KeyError: 'install_dir'
- x11-fm/nemo: KeyError: 'install_dir'
- x11/elementary-terminal: ERROR: Function does not take positional arguments.
- x11/gnome-session: ERROR: Function does not take positional arguments.
- x11/squeekboard: ERROR: Function does not take positional arguments.
- x11/virtboard: ERROR: Function does not take positional arguments.
Comment 21 commit-hook freebsd_committer 2021-11-03 09:41:39 UTC
A commit in branch main references this bug:

URL: https://cgit.FreeBSD.org/ports/commit/?id=6978d7653caac6974daf5493e5e657f7c7143a0e

commit 6978d7653caac6974daf5493e5e657f7c7143a0e
Author:     Jan Beich <jbeich@FreeBSD.org>
AuthorDate: 2021-11-03 09:33:36 +0000
Commit:     Jan Beich <jbeich@FreeBSD.org>
CommitDate: 2021-11-03 09:36:28 +0000

    x11/appmenu-registrar: drop duplicate localization

    po/meson.build:1:5: ERROR: Tried to create target "vala-panel-appmenu-nb.mo", but a target of that name already exists.

    https://gitlab.com/vala-panel-project/vala-panel-appmenu/-/commit/442bcebcc00e

    PR:             259080
    Reported by:    antoine (via exp-run)

 x11/appmenu-registrar/Makefile | 3 +++
 x11/appmenu-registrar/distinfo | 2 ++
 2 files changed, 5 insertions(+)
Comment 22 commit-hook freebsd_committer 2021-11-03 14:47:31 UTC
A commit in branch main references this bug:

URL: https://cgit.FreeBSD.org/ports/commit/?id=501557fb79bb1b36da5732ad5dbd76fd3e3ef81f

commit 501557fb79bb1b36da5732ad5dbd76fd3e3ef81f
Author:     Jan Beich <jbeich@FreeBSD.org>
AuthorDate: 2021-11-03 14:41:52 +0000
Commit:     Jan Beich <jbeich@FreeBSD.org>
CommitDate: 2021-11-03 14:46:38 +0000

    sysutils/gnome-settings-daemon: fix comparison with Meson option

    meson.build:86:3: ERROR: The `==` operator of str does not accept objects of type bool (True)

    https://gitlab.gnome.org/GNOME/gnome-settings-daemon/-/commit/28e28e9e5983

    PR:             259080
    Reported by:    antoine (via exp-run)
    Regressed by:   https://github.com/mesonbuild/meson/commit/a6c9a151d3ce

 sysutils/gnome-settings-daemon/Makefile | 3 +++
 sysutils/gnome-settings-daemon/distinfo | 2 ++
 2 files changed, 5 insertions(+)
Comment 23 commit-hook freebsd_committer 2021-11-03 15:19:37 UTC
A commit in branch main references this bug:

URL: https://cgit.FreeBSD.org/ports/commit/?id=f5989bb293aeacaaa1aa3508c84e8a8179623b24

commit f5989bb293aeacaaa1aa3508c84e8a8179623b24
Author:     Jan Beich <jbeich@FreeBSD.org>
AuthorDate: 2021-11-03 15:15:06 +0000
Commit:     Jan Beich <jbeich@FreeBSD.org>
CommitDate: 2021-11-03 15:18:49 +0000

    x11/gnome-shell: drop unused Meson options after 8a016444ba57

    meson.build:1:0: ERROR: Unknown options: "python"

    Was never supported upstream.

    PR:             259080
    Regressed by:   https://github.com/mesonbuild/meson/commit/dbf2ace6ca1c

 x11/gnome-shell/Makefile | 1 -
 1 file changed, 1 deletion(-)
Comment 24 commit-hook freebsd_committer 2021-11-03 18:07:08 UTC
A commit in branch main references this bug:

URL: https://cgit.FreeBSD.org/ports/commit/?id=43cc9e6350f0df54ffda5f462bb6553369f6e496

commit 43cc9e6350f0df54ffda5f462bb6553369f6e496
Author:     Jan Beich <jbeich@FreeBSD.org>
AuthorDate: 2021-11-03 17:55:57 +0000
Commit:     Jan Beich <jbeich@FreeBSD.org>
CommitDate: 2021-11-03 18:03:43 +0000

    misc/urbit: drop unused Meson keyword

    subprojects/commonmark-legacy/meson.build:30:0: ERROR: Got unknown keyword arguments "version"
    subprojects/libscrypt/meson.build:17:0: ERROR: Got unknown keyword arguments "version"
    subprojects/ed25519/meson.build:21:0: ERROR: Got unknown keyword arguments "version"
    subprojects/murmur3/meson.build:7:0: ERROR: Got unknown keyword arguments "version"
    subprojects/softfloat3/meson.build:321:0: ERROR: Got unknown keyword arguments "version"

    PR:             259080
    Reported by:    antoine (via exp-run)
    Regressed by:   https://github.com/mesonbuild/meson/commit/88a1bed81b7d

 .../patch-subprojects_commonmark-legacy_meson.build (new)     | 10 ++++++++++
 misc/urbit/files/patch-subprojects_ed25519_meson.build (new)  | 10 ++++++++++
 .../urbit/files/patch-subprojects_libscrypt_meson.build (new) | 11 +++++++++++
 misc/urbit/files/patch-subprojects_murmur3_meson.build (new)  | 11 +++++++++++
 .../files/patch-subprojects_softfloat3_meson.build (new)      | 10 ++++++++++
 5 files changed, 52 insertions(+)
Comment 25 commit-hook freebsd_committer 2021-11-03 18:07:08 UTC
A commit in branch main references this bug:

URL: https://cgit.FreeBSD.org/ports/commit/?id=64ea39283584566eccc8536f631e84b5a10b40c2

commit 64ea39283584566eccc8536f631e84b5a10b40c2
Author:     Jan Beich <jbeich@FreeBSD.org>
AuthorDate: 2021-11-03 17:49:26 +0000
Commit:     Jan Beich <jbeich@FreeBSD.org>
CommitDate: 2021-11-03 18:03:42 +0000

    x11-wm/enlightenment: drop unused Meson keyword after ce23e82aac23

    meson.build:117:8: ERROR: compiler.links got unknown keyword arguments "link_args"

    PR:             259080
    Reported by:    antoine (via exp-run)
    Regressed by:   https://github.com/mesonbuild/meson/commit/88a1bed81b7d

 x11-wm/enlightenment/files/patch-meson.build (new) | 11 +++++++++++
 1 file changed, 11 insertions(+)
Comment 26 commit-hook freebsd_committer 2021-11-03 18:55:16 UTC
A commit in branch main references this bug:

URL: https://cgit.FreeBSD.org/ports/commit/?id=6a73c70f44126dafe17e46a6ce93ef64d2bb4522

commit 6a73c70f44126dafe17e46a6ce93ef64d2bb4522
Author:     Jan Beich <jbeich@FreeBSD.org>
AuthorDate: 2021-11-03 17:55:57 +0000
Commit:     Jan Beich <jbeich@FreeBSD.org>
CommitDate: 2021-11-03 18:54:13 +0000

    multimedia/handbrake: disable ldconfig during build

    ld-elf.so.1: Shared object "liblz4.so.1" not found, required by "libarchive.so.13"
    gmake[4]: *** [common/CMakeFiles/common.dir/build.make:134: common/CMakeFiles/common.dir/x86/intrapred8.asm.o] Error 1

    $ ldconfig -r
    /var/run/ld-elf.so.hints:
            search directories:

    PR:             259080
    Reported by:    antoine (via exp-run)
    Regressed by:   https://github.com/mesonbuild/meson/commit/2c3a68bc30cf

 multimedia/handbrake/Makefile | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)
Comment 28 Jan Beich freebsd_committer 2021-11-07 20:33:09 UTC
(In reply to commit-hook from comment #21)
>    po/meson.build:1:5: ERROR: Tried to create target "vala-panel-appmenu-nb.mo", but a target of that name already exists.

Bisected to https://github.com/mesonbuild/meson/commit/487d45c1e5bf
Comment 29 commit-hook freebsd_committer 2021-11-07 20:34:50 UTC
A commit in branch main references this bug:

URL: https://cgit.FreeBSD.org/ports/commit/?id=ab33834c94052e9b8a36c836e752364d0b3bf9e0

commit ab33834c94052e9b8a36c836e752364d0b3bf9e0
Author:     Jan Beich <jbeich@FreeBSD.org>
AuthorDate: 2021-11-07 19:59:12 +0000
Commit:     Jan Beich <jbeich@FreeBSD.org>
CommitDate: 2021-11-07 20:34:11 +0000

    sysutils/tracker-miners: drop unused Meson options after 951c1f5d1c73

    meson.build:1:0: ERROR: Unknown options: "charset_detenction, stemmer, unicode_support"

    https://gitlab.gnome.org/GNOME/tracker-miners/-/commit/bce1ed6ff742
    https://gitlab.gnome.org/GNOME/tracker-miners/-/commit/277b2a868de1

    PR:             259080
    Reported by:    antoine (via exp-run)
    Regressed by:   https://github.com/mesonbuild/meson/commit/dbf2ace6ca1c

 sysutils/tracker-miners/Makefile | 4 +---
 1 file changed, 1 insertion(+), 3 deletions(-)
Comment 30 commit-hook freebsd_committer 2021-11-07 20:34:51 UTC
A commit in branch main references this bug:

URL: https://cgit.FreeBSD.org/ports/commit/?id=e6c926b80de4f40ed3d27c016ec4e43e2cd32d52

commit e6c926b80de4f40ed3d27c016ec4e43e2cd32d52
Author:     Jan Beich <jbeich@FreeBSD.org>
AuthorDate: 2021-11-07 20:15:39 +0000
Commit:     Jan Beich <jbeich@FreeBSD.org>
CommitDate: 2021-11-07 20:34:10 +0000

    devel/libvirt-glib: fix typo in Meson option after f50787b7ef34

    meson.build:1:0: ERROR: Unknown options: "vala"

    PR:             259080
    Reported by:    antoine (via exp-run)
    Regressed by:   https://github.com/mesonbuild/meson/commit/dbf2ace6ca1c

 devel/libvirt-glib/Makefile | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)
Comment 31 commit-hook freebsd_committer 2021-11-07 20:34:52 UTC
A commit in branch main references this bug:

URL: https://cgit.FreeBSD.org/ports/commit/?id=9dac5fe121bc08e3bb704a2ade1f02af19f78646

commit 9dac5fe121bc08e3bb704a2ade1f02af19f78646
Author:     Jan Beich <jbeich@FreeBSD.org>
AuthorDate: 2021-11-07 20:08:06 +0000
Commit:     Jan Beich <jbeich@FreeBSD.org>
CommitDate: 2021-11-07 20:34:10 +0000

    deskutils/bijiben: drop unused Meson options after 081c758935b7

    meson.build:1:0: ERROR: Unknown options: "zeitgeist"

    https://gitlab.gnome.org/GNOME/bijiben/-/commit/bcfbd9a4113b

    PR:             259080
    Reported by:    antoine (via exp-run)
    Regressed by:   https://github.com/mesonbuild/meson/commit/dbf2ace6ca1c

 deskutils/bijiben/Makefile | 3 +--
 1 file changed, 1 insertion(+), 2 deletions(-)
Comment 32 commit-hook freebsd_committer 2021-11-07 20:34:53 UTC
A commit in branch main references this bug:

URL: https://cgit.FreeBSD.org/ports/commit/?id=03e8c682e43f810add5fb593d00ddc3fd62f9001

commit 03e8c682e43f810add5fb593d00ddc3fd62f9001
Author:     Jan Beich <jbeich@FreeBSD.org>
AuthorDate: 2021-11-07 20:31:29 +0000
Commit:     Jan Beich <jbeich@FreeBSD.org>
CommitDate: 2021-11-07 20:34:10 +0000

    x11/mate-applet-appmenu: drop duplicate localization

    po/meson.build:1:5: ERROR: Tried to create target "vala-panel-appmenu-nb.mo", but a target of that name already exists.

    https://gitlab.com/vala-panel-project/vala-panel-appmenu/-/commit/442bcebcc00e

    PR:             259080
    Reported by:    antoine (via exp-run)
    Regressed by:   https://github.com/mesonbuild/meson/commit/487d45c1e5bf

 x11/mate-applet-appmenu/Makefile | 3 +++
 x11/mate-applet-appmenu/distinfo | 2 ++
 2 files changed, 5 insertions(+)
Comment 33 commit-hook freebsd_committer 2021-11-07 20:34:54 UTC
A commit in branch main references this bug:

URL: https://cgit.FreeBSD.org/ports/commit/?id=0c9b91e89c296422d8ee88fd77555e5476e3189a

commit 0c9b91e89c296422d8ee88fd77555e5476e3189a
Author:     Jan Beich <jbeich@FreeBSD.org>
AuthorDate: 2021-11-07 20:20:10 +0000
Commit:     Jan Beich <jbeich@FreeBSD.org>
CommitDate: 2021-11-07 20:34:10 +0000

    multimedia/totem: drop unused Meson options after 38ae40f5daf7

    meson.build:1:0: ERROR: Unknown options: "enable-vala"

    https://gitlab.gnome.org/GNOME/totem/-/commit/627c1ee182ea

    PR:             259080
    Reported by:    antoine (via exp-run)
    Regressed by:   https://github.com/mesonbuild/meson/commit/dbf2ace6ca1c

 multimedia/totem/Makefile | 9 ---------
 1 file changed, 9 deletions(-)
Comment 34 commit-hook freebsd_committer 2021-11-07 20:34:55 UTC
A commit in branch main references this bug:

URL: https://cgit.FreeBSD.org/ports/commit/?id=527ddf1cf0abba96ff512059138821a9a75f43cd

commit 527ddf1cf0abba96ff512059138821a9a75f43cd
Author:     Jan Beich <jbeich@FreeBSD.org>
AuthorDate: 2021-11-07 20:12:22 +0000
Commit:     Jan Beich <jbeich@FreeBSD.org>
CommitDate: 2021-11-07 20:34:11 +0000

    net-im/folks: drop unused Meson options after 82ec8506217a

    meson.build:1:0: ERROR: Unknown options: "tracker_backend"

    https://gitlab.gnome.org/GNOME/folks/-/commit/e9215d339325

    PR:             259080
    Reported by:    antoine (via exp-run)
    Regressed by:   https://github.com/mesonbuild/meson/commit/dbf2ace6ca1c

 net-im/folks/Makefile | 9 +--------
 1 file changed, 1 insertion(+), 8 deletions(-)
Comment 35 commit-hook freebsd_committer 2021-11-07 20:35:56 UTC
A commit in branch main references this bug:

URL: https://cgit.FreeBSD.org/ports/commit/?id=4bdff1539b59ebfd7e4781d462e187e907f3a4bc

commit 4bdff1539b59ebfd7e4781d462e187e907f3a4bc
Author:     Jan Beich <jbeich@FreeBSD.org>
AuthorDate: 2021-11-07 20:30:22 +0000
Commit:     Jan Beich <jbeich@FreeBSD.org>
CommitDate: 2021-11-07 20:34:10 +0000

    x11/xfce4-appmenu-plugin: drop duplicate localization

    po/meson.build:1:5: ERROR: Tried to create target "vala-panel-appmenu-nb.mo", but a target of that name already exists.

    https://gitlab.com/vala-panel-project/vala-panel-appmenu/-/commit/442bcebcc00e

    PR:             259080
    Reported by:    antoine (via exp-run)
    Regressed by:   https://github.com/mesonbuild/meson/commit/487d45c1e5bf

 x11/xfce4-appmenu-plugin/Makefile | 3 +++
 x11/xfce4-appmenu-plugin/distinfo | 2 ++
 2 files changed, 5 insertions(+)
Comment 36 Jan Beich freebsd_committer 2021-11-12 17:55:39 UTC
Ping to portmgr@. I need this for https://github.com/mpv-player/mpv/pull/8840
Comment 38 commit-hook freebsd_committer 2021-11-13 20:03:35 UTC
A commit in branch main references this bug:

URL: https://cgit.FreeBSD.org/ports/commit/?id=bf3dd0f6c5f0b9ea88e59d588cd6b1819f6ebeff

commit bf3dd0f6c5f0b9ea88e59d588cd6b1819f6ebeff
Author:     Jan Beich <jbeich@FreeBSD.org>
AuthorDate: 2021-11-13 19:49:55 +0000
Commit:     Jan Beich <jbeich@FreeBSD.org>
CommitDate: 2021-11-13 20:02:35 +0000

    deskutils/gnome-contacts: chase Meson options name after 30c5e3bf165c

    meson.build:1:0: ERROR: Unknown options: "with-cheese, with-manpage"

    https://gitlab.gnome.org/GNOME/gnome-contacts/-/commit/f429a775d8de
    https://gitlab.gnome.org/GNOME/gnome-contacts/-/commit/77fa086cfd82

    PR:             259080
    Reported by:    antoine (via exp-run)
    Regressed by:   https://github.com/mesonbuild/meson/commit/dbf2ace6ca1c

 deskutils/gnome-contacts/Makefile | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)
Comment 39 commit-hook freebsd_committer 2021-11-13 20:03:36 UTC
A commit in branch main references this bug:

URL: https://cgit.FreeBSD.org/ports/commit/?id=496e5b6d8e28a1d3590ee2cadc4ec6d2bf6be202

commit 496e5b6d8e28a1d3590ee2cadc4ec6d2bf6be202
Author:     Jan Beich <jbeich@FreeBSD.org>
AuthorDate: 2021-11-13 19:41:36 +0000
Commit:     Jan Beich <jbeich@FreeBSD.org>
CommitDate: 2021-11-13 20:02:35 +0000

    x11-fm/nautilus: chase Meson options name after 951c1f5d1c73

    meson.build:1:0: ERROR: Unknown options: "enable-packagekit, enable-selinux"

    https://gitlab.gnome.org/GNOME/nautilus/-/commit/983892a65674

    PR:             259080
    Reported by:    antoine (via exp-run)
    Regressed by:   https://github.com/mesonbuild/meson/commit/dbf2ace6ca1c

 x11-fm/nautilus/Makefile | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)
Comment 40 commit-hook freebsd_committer 2021-11-13 21:06:54 UTC
A commit in branch main references this bug:

URL: https://cgit.FreeBSD.org/ports/commit/?id=fa8734214c04c8a14dd3878e3cec92d54e8b8d65

commit fa8734214c04c8a14dd3878e3cec92d54e8b8d65
Author:     Jan Beich <jbeich@FreeBSD.org>
AuthorDate: 2021-11-13 20:32:43 +0000
Commit:     Jan Beich <jbeich@FreeBSD.org>
CommitDate: 2021-11-13 21:06:18 +0000

    devel/libpeas: work around incomplete target dependency

    ../tests/libpeas/extension-c.c:32:10: fatal error: 'plugins/embedded/embedded-resources.h' file not found
     #include "plugins/embedded/embedded-resources.h"
              ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

    PR:             259080
    Reported by:    antoine (via exp-run)
    Regressed by:   https://github.com/mesonbuild/meson/commit/22c38a000673

 devel/libpeas/Makefile | 5 +++++
 1 file changed, 5 insertions(+)
Comment 41 commit-hook freebsd_committer 2021-11-14 00:14:28 UTC
A commit in branch main references this bug:

URL: https://cgit.FreeBSD.org/ports/commit/?id=1ce92066a710618e808a23dd9e0a8f3ad72040cd

commit 1ce92066a710618e808a23dd9e0a8f3ad72040cd
Author:     Jan Beich <jbeich@FreeBSD.org>
AuthorDate: 2021-11-14 00:08:53 +0000
Commit:     Jan Beich <jbeich@FreeBSD.org>
CommitDate: 2021-11-14 00:10:57 +0000

    devel/gnome-builder: drop unused Meson options after 4ea339cae9eb

    meson.build:1:0: ERROR: Unknown options: "plugin_jedi"

    https://gitlab.gnome.org/GNOME/gnome-builder/-/commit/53143a789db8

    PR:             259080
    Regressed by:   https://github.com/mesonbuild/meson/commit/dbf2ace6ca1c

 devel/gnome-builder/Makefile | 6 ------
 1 file changed, 6 deletions(-)
Comment 42 Antoine Brodin freebsd_committer 2021-11-14 20:10:56 UTC
Exp-run looks fine
Comment 43 commit-hook freebsd_committer 2021-11-14 20:14:47 UTC
A commit in branch main references this bug:

URL: https://cgit.FreeBSD.org/ports/commit/?id=665e4e5edb6d6b60b6ae2e7ddf83064111b25e48

commit 665e4e5edb6d6b60b6ae2e7ddf83064111b25e48
Author:     Jan Beich <jbeich@FreeBSD.org>
AuthorDate: 2021-11-02 20:55:25 +0000
Commit:     Jan Beich <jbeich@FreeBSD.org>
CommitDate: 2021-11-14 20:12:17 +0000

    devel/meson: update to 0.60.1

    Changes:        https://mesonbuild.com/Release-notes-for-0-60-0.html
    PR:             259080
    Reported by:    GitHub (watch releases)
    Exp-run by:     antoine

 devel/meson/Makefile                                           |  2 +-
 devel/meson/distinfo                                           |  6 +++---
 ...tch-run__unittests.py => patch-unittests_linuxliketests.py} |  6 +++---
 .../files/patch-data_freedesktop__generate.sh (new)            | 10 ++++++++++
 4 files changed, 17 insertions(+), 7 deletions(-)
Comment 44 Jan Beich freebsd_committer 2021-11-14 20:20:16 UTC
Pushed without waiting for explicit approval by desktop@ because (mainly gnome@) updates risk introducing regressions.
Comment 45 commit-hook freebsd_committer 2021-11-21 11:07:56 UTC
A commit in branch main references this bug:

URL: https://cgit.FreeBSD.org/ports/commit/?id=51c83df293e0770cfb9778b53d55149fa3d27b3f

commit 51c83df293e0770cfb9778b53d55149fa3d27b3f
Author:     Jan Beich <jbeich@FreeBSD.org>
AuthorDate: 2021-11-19 04:06:57 +0000
Commit:     Jan Beich <jbeich@FreeBSD.org>
CommitDate: 2021-11-21 11:06:33 +0000

    devel/meson: temporarily disable ldconfig after 665e4e5edb6d

    $ su root -c 'meson install -C foo_build'
    $ meson
    ld-elf.so.1: Shared object "libpython3.8.so.1.0" not found, required by "python3.8"

    PR:             259080

 devel/meson/Makefile                                 |  1 +
 devel/meson/files/patch-mesonbuild_minstall.py (new) | 16 ++++++++++++++++
 multimedia/handbrake/Makefile                        |  2 +-
 3 files changed, 18 insertions(+), 1 deletion(-)
Comment 46 Tobias C. Berner freebsd_committer 2021-11-21 16:01:56 UTC
lgtm as desktop@