Bug 259173 - audio/soundtouch: Switch to MASTER_SITES and fix i386
Summary: audio/soundtouch: Switch to MASTER_SITES and fix i386
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Daniel Engberg
URL:
Keywords:
: 259390 (view as bug list)
Depends on:
Blocks: 258107
  Show dependency treegraph
 
Reported: 2021-10-14 20:59 UTC by Daniel Engberg
Modified: 2021-10-25 17:46 UTC (History)
2 users (show)

See Also:
crees: maintainer-feedback+


Attachments
Patch for soundtouch (2.08 KB, patch)
2021-10-14 20:59 UTC, Daniel Engberg
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Daniel Engberg freebsd_committer 2021-10-14 20:59:28 UTC
Created attachment 228706 [details]
Patch for soundtouch

Switch to static tarballs, unbreak i386 builds

Poudriere testport OK 13.0-RELEASE (i386)

References:
https://codeberg.org/soundtouch/soundtouch
https://lists.freebsd.org/archives/freebsd-pkg-fallout/2021-October/124516.html
Comment 1 Bob Frazier 2021-10-21 15:53:45 UTC
Comment on attachment 228706 [details]
Patch for soundtouch

I applied the patch against the version found on freshports to correct a problem building the 2021Q4 port version (2.2).  Unfortunately they share the same file name for the tarball and 2.2 now has a checksum/size error trying to extract it.  Manually applying the patch to the freshports version (2.3.1) appears to fix that.
Comment 2 Daniel Engberg freebsd_committer 2021-10-24 09:25:21 UTC
*** Bug 259390 has been marked as a duplicate of this bug. ***
Comment 3 Chris Rees freebsd_committer 2021-10-24 17:06:48 UTC
If you've tested it and it works, please go ahead :)

Thanks a lot.
Comment 4 commit-hook freebsd_committer 2021-10-25 17:45:40 UTC
A commit in branch main references this bug:

URL: https://cgit.FreeBSD.org/ports/commit/?id=d47b0c46c281281607be32faacc8f969b1234a62

commit d47b0c46c281281607be32faacc8f969b1234a62
Author:     Daniel Engberg <diizzy@FreeBSD.org>
AuthorDate: 2021-10-25 17:42:33 +0000
Commit:     Daniel Engberg <diizzy@FreeBSD.org>
CommitDate: 2021-10-25 17:42:36 +0000

    audio/soundtouch: Switch to MASTER_SITES and fix i386

    Switch to static tarball, unbreak i386 builds

    References:
    https://codeberg.org/soundtouch/soundtouch
    https://lists.freebsd.org/archives/freebsd-pkg-fallout/2021-October/124516.html

    PR:             259173
    Approved by:    crees (port maintainer), arrowd (mentor)
    Differential Revision:  https://reviews.freebsd.org/D32639

 audio/soundtouch/Makefile | 20 +++++++++++---------
 audio/soundtouch/distinfo |  6 +++---
 2 files changed, 14 insertions(+), 12 deletions(-)
Comment 5 Daniel Engberg freebsd_committer 2021-10-25 17:46:05 UTC
Comitted, thanks!