Bug 259220 - Missing STL c++20 header 'format'
Summary: Missing STL c++20 header 'format'
Status: Closed DUPLICATE of bug 255374
Alias: None
Product: Base System
Classification: Unclassified
Component: standards (show other bugs)
Version: 12.2-STABLE
Hardware: Any Any
: --- Affects Only Me
Assignee: freebsd-toolchain (Nobody)
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-10-17 03:07 UTC by Yuri Victorovich
Modified: 2021-10-17 03:19 UTC (History)
2 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Yuri Victorovich freebsd_committer 2021-10-17 03:07:03 UTC
https://en.cppreference.com/w/cpp/utility/format/format
Comment 1 Kubilay Kocak freebsd_committer freebsd_triage 2021-10-17 03:12:44 UTC
@Yuri What was the failure case motivating the issue? Was there a port or software that otherwise has issues whilst building? Additional info/refs would be great.
Comment 2 Kubilay Kocak freebsd_committer freebsd_triage 2021-10-17 03:16:43 UTC
This appears to be a dupe of bug 255374, where the relevent headers were added, and MFC'd to stable/13 (but not stable/12).

We'll re-open that issue requesting a decision on what to do about 12.x

*** This bug has been marked as a duplicate of bug 255374 ***
Comment 3 Yuri Victorovich freebsd_committer 2021-10-17 03:19:40 UTC
(In reply to Kubilay Kocak from comment #1)

> What was the failure case motivating the issue?

I just manually tried '#include <format>'.