Bug 259260 - lang/mlton: Maintainer update to 20210816, and fix build for FreeBSD 12 and 13
Summary: lang/mlton: Maintainer update to 20210816, and fix build for FreeBSD 12 and 13
Status: Closed DUPLICATE of bug 259261
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Koichiro Iwao
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-10-19 06:44 UTC by Timothy Beyer
Modified: 2021-11-06 00:12 UTC (History)
2 users (show)

See Also:


Attachments
lang_mlton.diff (868.44 KB, patch)
2021-10-19 06:44 UTC, Timothy Beyer
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Timothy Beyer 2021-10-19 06:44:54 UTC
Created attachment 228824 [details]
lang_mlton.diff

File is attached (diff format).

Since this is a fix to another PR (noted below) and I am the port maintainer of lang/mlton, this port should be committed in order to resolve that respective PR.

I have updated to version 20210816 from the official github repository, and as a result, this port once again builds properly on FreeBSD 11, 12 and 13, on both i386 and amd64.

This version uses version and architecture specific bootstrap images, which I host on my own repository on github.  Although building on i386 can be notoriously difficult due to excessive memory usage, I have set the ram-slop conditionals such that it should build properly under normal circumstances.  I disable polyvariants on i386 to get slightly lower memory usage, which in many cases is just barely enough to get a clean build.

I have verified that the build works on FreeBSD 11.4-RELEASE, FreeBSD 12.2-RELEASE, and FreeBSD 13.0-RELEASE, both both i386 and amd64 on each, for a total number of 6 configurations.

Right now, I strongly recommend just using the default options, especially the native MLton bootstrap, as I haven't used the SMLNJ in a long while (it is extremely slow anyway), and I'm not entirely sure the POLYML option is officially supported by the MLton developers yet.  Further, the MINGW32 build is currently broken, but if someone can fix it, I will gladly incorporate a patch (I'll look into it going forward).  None of these features are necessary for full functionality on FreeBSD, fortunately.

Provided that this works for committers as well as it worked for me in testing, this should fully address PR https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=253607
Comment 1 Koichiro Iwao freebsd_committer 2021-10-19 07:40:35 UTC

*** This bug has been marked as a duplicate of bug 259261 ***
Comment 2 Kubilay Kocak freebsd_committer freebsd_triage 2021-11-06 00:12:17 UTC
^Triage: Assign to committer that resolved