Bug 259261 - lang/mlton: Maintainer update to 20210816, and fix build for FreeBSD 12 and 13
Summary: lang/mlton: Maintainer update to 20210816, and fix build for FreeBSD 12 and 13
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Koichiro Iwao
URL:
Keywords:
: 259260 (view as bug list)
Depends on:
Blocks: 253607
  Show dependency treegraph
 
Reported: 2021-10-19 06:45 UTC by Timothy Beyer
Modified: 2021-11-06 00:12 UTC (History)
2 users (show)

See Also:


Attachments
lang_mlton.diff (868.44 KB, patch)
2021-10-19 06:46 UTC, Timothy Beyer
no flags Details | Diff
lang_mlton.diff (git format-patch version) (871.46 KB, patch)
2021-10-19 08:10 UTC, Timothy Beyer
no flags Details | Diff
lang_mlton.diff (fix documentation dependency from asciidoc to htmldoc) (871.37 KB, patch)
2021-10-19 10:29 UTC, Timothy Beyer
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Timothy Beyer 2021-10-19 06:45:12 UTC
File is attached (diff format).

Since this is a fix to another PR (noted below) and I am the port maintainer of lang/mlton, this port should be committed in order to resolve that respective PR.

I have updated to version 20210816 from the official github repository, and as a result, this port once again builds properly on FreeBSD 11, 12 and 13, on both i386 and amd64.

This version uses version and architecture specific bootstrap images, which I host on my own repository on github.  Although building on i386 can be notoriously difficult due to excessive memory usage, I have set the ram-slop conditionals such that it should build properly under normal circumstances.  I disable polyvariants on i386 to get slightly lower memory usage, which in many cases is just barely enough to get a clean build.

I have verified that the build works on FreeBSD 11.4-RELEASE, FreeBSD 12.2-RELEASE, and FreeBSD 13.0-RELEASE, both both i386 and amd64 on each, for a total number of 6 configurations.

Right now, I strongly recommend just using the default options, especially the native MLton bootstrap, as I haven't used the SMLNJ in a long while (it is extremely slow anyway), and I'm not entirely sure the POLYML option is officially supported by the MLton developers yet.  Further, the MINGW32 build is currently broken, but if someone can fix it, I will gladly incorporate a patch (I'll look into it going forward).  None of these features are necessary for full functionality on FreeBSD, fortunately.

Provided that this works for committers as well as it worked for me in testing, this should fully address PR https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=253607
Comment 1 Timothy Beyer 2021-10-19 06:46:53 UTC
Created attachment 228825 [details]
lang_mlton.diff

add missing attachment that was missing when I first created the PR
Comment 2 Timothy Beyer 2021-10-19 07:00:22 UTC
this is an unintentional duplicate of https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=259260, please delete this PR, my apologies
Comment 3 Koichiro Iwao freebsd_committer 2021-10-19 07:40:35 UTC
*** Bug 259260 has been marked as a duplicate of this bug. ***
Comment 4 Koichiro Iwao freebsd_committer 2021-10-19 07:41:10 UTC
Can you commit it to your local git repo and submit the patch created by `git format-patch`?
Comment 5 Timothy Beyer 2021-10-19 08:10:23 UTC
Created attachment 228828 [details]
lang_mlton.diff (git format-patch version)

git format-patch version of the prior patch
Comment 6 Timothy Beyer 2021-10-19 08:12:17 UTC
(In reply to Koichiro Iwao from comment #4)
done, thanks for letting me know
Comment 7 Koichiro Iwao freebsd_committer 2021-10-19 08:32:30 UTC
It failed to build:

===>   mlton-20210816 depends on executable: htmldoc - not found
*** Error code 1

Stop.
make: stopped in /usr/ports/lang/mlton
build of lang/mlton | mlton-20210816 ended at Tue Oct 19 17:31:13 JST 2021
build time: 00:00:11
!!! build failure encountered !!!
[00:00:18] Error: Build failed in phase: build-depends
Comment 8 Timothy Beyer 2021-10-19 10:29:12 UTC
Created attachment 228829 [details]
lang_mlton.diff (fix documentation dependency from asciidoc to htmldoc)

fix documentation dependency from asciidoc to htmldoc
Comment 9 commit-hook freebsd_committer 2021-10-20 07:43:59 UTC
A commit in branch main references this bug:

URL: https://cgit.FreeBSD.org/ports/commit/?id=042847b1b437634da916eb1386273a7fd8777a89

commit 042847b1b437634da916eb1386273a7fd8777a89
Author:     Timothy Beyer <beyert_freebsd@fastmail.net>
AuthorDate: 2021-10-19 10:24:12 +0000
Commit:     Koichiro Iwao <meta@FreeBSD.org>
CommitDate: 2021-10-20 07:42:18 +0000

    lang/mlton: Update to 20210816

    and fix build for FreeBSD 12 and 13.

    PR:             259261

 lang/mlton/Makefile                                |  280 +-
 lang/mlton/distinfo                                |   21 +-
 lang/mlton/files/add-local-cross (gone)            |  191 -
 lang/mlton/files/ml.grm.sig (gone)                 |   88 -
 lang/mlton/files/ml.grm.sml (gone)                 | 5497 -------------------
 lang/mlton/files/ml.lex.sml (gone)                 | 5660 --------------------
 lang/mlton/files/mlb.grm.sig (gone)                |   32 -
 lang/mlton/files/mlb.grm.sml (gone)                |  894 ----
 lang/mlton/files/mlb.lex.sml (gone)                | 1854 -------
 lang/mlton/files/patch-Makefile                    |   40 +-
 .../files/patch-lib_mlrisc-lib_Makefile (new)      |   12 +
 lang/mlton/files/patch-runtime-Makefile (gone)     |   67 -
 lang/mlton/files/patch-runtime_gc_int-inf.c (gone) |   13 -
 lang/mlton/files/upgrade-basis.sml (gone)          |   68 -
 lang/mlton/files/yacc.grm.sig (gone)               |   54 -
 lang/mlton/files/yacc.grm.sml (gone)               | 1053 ----
 lang/mlton/files/yacc.lex.sml (gone)               |  901 ----
 lang/mlton/pkg-plist                               | 1797 +------
 18 files changed, 416 insertions(+), 18106 deletions(-)
Comment 10 Koichiro Iwao freebsd_committer 2021-10-20 07:45:03 UTC
Committed, thanks!