Bug 259266 - devel/py-setuptools_scm: runs 'git archive' during build
Summary: devel/py-setuptools_scm: runs 'git archive' during build
Status: Closed DUPLICATE of bug 258891
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: Kubilay Kocak
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-10-19 11:55 UTC by Norikatsu Shigemura
Modified: 2021-10-19 22:48 UTC (History)
2 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Norikatsu Shigemura 2021-10-19 11:55:22 UTC
Many python modules required py-setuptools_scm.
And setuptools_scm run 'git archive --prefix /usr/ports HEAD' on 'make stage'.
But it's too meaningless and careless, because they want its version,
not ports version.

SEE ALSO: https://github.com/pypa/setuptools_scm/issues/353

Sorry, I don't know how to fix, yet. I know some workaround:

- chmod 0000 /usr/local/libexec/git-core/git-archive
- pkg -y delete git
- mv /usr/ports/.git /usr/ports/.git.IGNORE and make install, then revert.
- etc, etc...
Comment 1 Robert Clausecker 2021-10-19 11:57:25 UTC
This is a duplicate of bug #258891.
Comment 2 Norikatsu Shigemura 2021-10-19 17:29:40 UTC
Ah, OK, I see. #258891 is what I was looking for.

*** This bug has been marked as a duplicate of bug 258891 ***