Bug 259281 - security/gnupg: problems after upgrade to 2.3.3
Summary: security/gnupg: problems after upgrade to 2.3.3
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Adam Weinberger
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-10-19 17:33 UTC by Aleks Bunin
Modified: 2021-11-02 11:25 UTC (History)
3 users (show)

See Also:


Attachments
Patch for common/homedir.c, bump PORTREVISION in Makefile (1.74 KB, patch)
2021-10-26 08:58 UTC, FiLiS
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Aleks Bunin 2021-10-19 17:33:14 UTC
After upgrade to gnupg 2.3.3 on multiple systems I started to experience issues of connecting to gpg-agent. While gpg-agent is running, when I attempt to send 


    gpg-connect-agent KILLAGENT /bye


I run into issue where one of the processes get stuck.

In addition to this, when running any gnupg command, I see error message 

   gpg: error reading symlink '/proc/curproc/file': No such file or directory


I understand that there is not a lot of information, but I don't see a way to troubleshoot this further.

Fixed this by reverting to 2.3.2


    sudo pkg install /var/cache/pkg/gnupg-2.3.2.pkg
Comment 1 Aleks Bunin 2021-10-19 17:41:54 UTC
Looks like issue with /proc is discussed upstream at https://dev.gnupg.org/T5656
Comment 2 FiLiS 2021-10-25 07:04:49 UTC
There is a commit that seems to fix it:

https://dev.gnupg.org/rG4cb44914b57a8db9d2f0d24e11d2b5e6fedc0a87

Maybe we can patch the port until 2.3.4 is released?
Comment 3 Pietro Cerutti freebsd_committer 2021-10-25 07:51:30 UTC
Yes please.
Comment 4 FiLiS 2021-10-26 08:58:54 UTC
Created attachment 229040 [details]
Patch for common/homedir.c, bump PORTREVISION in Makefile

I tried to make a patch for the port that also bumps the PORTREVISION in Makefile. Tests seem to work okay. With the patch applied, gpg now doesn't complain about missing procfs.
Comment 5 Adam Weinberger freebsd_committer 2021-11-02 11:25:53 UTC
Committed in 7b6ca19a8048. Sorry, forgot to link the PR in the commit message.

Thanks for doing the work on this!