Bug 259352 - FreeBSD-12.2-RELEASE boot failure on Raspberry Pi 4 Model B Rev 1.4
Summary: FreeBSD-12.2-RELEASE boot failure on Raspberry Pi 4 Model B Rev 1.4
Status: Closed Works As Intended
Alias: None
Product: Base System
Classification: Unclassified
Component: arm (show other bugs)
Version: 12.2-STABLE
Hardware: arm64 Any
: --- Affects Many People
Assignee: freebsd-arm (Nobody)
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-10-22 10:04 UTC by Greg Donald
Modified: 2021-10-23 03:13 UTC (History)
2 users (show)

See Also:


Attachments
Screenshot of boot failure (295.50 KB, image/jpeg)
2021-10-22 10:13 UTC, Greg Donald
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Greg Donald 2021-10-22 10:04:40 UTC
FreeBSD-12.2-RELEASE-arm64-aarch64-RPI3.img fails to boot on my Raspberry Pi 4 Model B Rev 1.4.

I've confirmed my sdcard and board both work by installing Debian which boots fine.

I've attached a screenshot.
Comment 1 Greg Donald 2021-10-22 10:13:30 UTC
Created attachment 228942 [details]
Screenshot of boot failure
Comment 2 Kubilay Kocak freebsd_committer freebsd_triage 2021-10-22 23:19:01 UTC
*** Bug 259353 has been marked as a duplicate of this bug. ***
Comment 3 Mark Millard 2021-10-23 00:44:48 UTC
(In reply to Greg Donald from comment #0)

FreeBSD 12.x makes no claim to support RPi4B's, 13.0 does.
There are RPi4B specifics in 13 and later that were never
put back in 12.x as far as I know.

As far as I can tell this submittal should be rejected as
something like no-plan-to-support (so works-as-intended?).
Comment 4 Li-Wen Hsu freebsd_committer 2021-10-23 03:13:06 UTC
FreeBSD 12 doesn't support Raspberry Pi 4, as the image name shows, it supports 3 only.