Bug 259366 - iwm fails to attach on Lenovo ThinkCentre m920q
Summary: iwm fails to attach on Lenovo ThinkCentre m920q
Status: Open
Alias: None
Product: Base System
Classification: Unclassified
Component: kern (show other bugs)
Version: 13.0-RELEASE
Hardware: amd64 Any
: --- Affects Only Me
Assignee: freebsd-wireless (Nobody)
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-10-22 20:51 UTC by David Demelier
Modified: 2021-10-25 14:54 UTC (History)
2 users (show)

See Also:


Attachments
dmesg.txt (10.48 KB, text/plain)
2021-10-22 20:51 UTC, David Demelier
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description David Demelier 2021-10-22 20:51:30 UTC
Created attachment 228954 [details]
dmesg.txt

My machine has a Intel AC9560 as seen in pciconf -lv:

iwm0@pci0:0:20:3:	class=0x028000 rev=0x10 hdr=0x00 vendor=0x8086 device=0xa370 subvendor=0x8086 subdevice=0x0030
    vendor     = 'Intel Corporation'
    device     = 'Wireless-AC 9560 [Jefferson Peak]'
    class      = network

But when booting it fails to attach it:

iwm0: <Intel(R) Dual Band Wireless AC 9560> mem 0xb1134000-0xb1137fff at device 20.3 on pci0
iwm0: fw chunk addr 0x404000 len 712 failed to load
iwm0: iwm_pcie_load_section: Could not load the [0] uCode section
iwm0: iwm_start_fw: failed 60
iwm0: Failed to start INIT ucode: 60

I have this in my loader.conf:

if_iwm_load="YES"
iwm3160fw_load="YES"                                                                                                      
iwm3168fw_load="YES"                                                                                                      
iwm7260fw_load="YES"                                                                                                      
iwm7265fw_load="YES"                                                                                                      
iwm8000Cfw_load="YES"                                                                                                     
iwm8265fw_load="YES"                                                                                                      
iwm9000fw_load="YES"                                                                                                      
iwm9260fw_load="YES" 

I've attached the whole dmesg, this machine is running 13.0-RELEASE, amd64.
Comment 1 Bjoern A. Zeeb freebsd_committer 2021-10-23 15:39:45 UTC
I'll likely take this and would suggest simply trying https://wiki.freebsd.org/WiFi/Iwlwifi  once the next snapshot is out in a few days.  I'll get back to you then.