Bug 259441 - System not booting with "KDB: debugger backends: ddb"
Summary: System not booting with "KDB: debugger backends: ddb"
Status: Closed Not A Bug
Alias: None
Product: Base System
Classification: Unclassified
Component: kern (show other bugs)
Version: 12.2-RELEASE
Hardware: amd64 Any
: --- Affects Some People
Assignee: freebsd-bugs (Nobody)
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-10-25 18:06 UTC by Sesshoumaru
Modified: 2021-11-05 15:41 UTC (History)
1 user (show)

See Also:


Attachments
Boot Hang (819.60 KB, image/jpeg)
2021-10-25 18:06 UTC, Sesshoumaru
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Sesshoumaru 2021-10-25 18:06:14 UTC
Created attachment 229028 [details]
Boot Hang

I have a TrueNAS 12 system (using FreeBSD 12 under the hood) which suddenly stopped booten with the message "KDB: debugger backends: ddb" (see attachements). The system is a Supermicro Server CSE-848X 4x 12C Xeon E7-4850 v2 2,3GHz 256GB ECC.

There was no update or anything done. After a regular shutdown it comes not up anymore. SLIT tables shoes my 4 NUMA nodes but then stops, going into a reboot cycle which then finally comes to hold / hang.
Comment 1 Ed Maste freebsd_committer 2021-10-25 21:30:58 UTC
Does a verbose boot (select from the loader prompt) offer any insight?
Comment 2 Sesshoumaru 2021-10-26 15:18:59 UTC
(In reply to Ed Maste from comment #1)
The right side of the attached screehshot is already the verbose output. After the SLIT.Localities everythings stops. I was told that the next expected line would be the resolution of the console window. I tried to disable the redirction of the serial console, but it does not help.
Comment 3 Sesshoumaru 2021-10-27 17:46:37 UTC
Foud the issue.
Even if the memory passed the POST check, there were 3 defektive ECC DIMMs.
Comment 4 Ed Maste freebsd_committer 2021-11-05 15:41:06 UTC
Issue found: defective memory