Bug 259457 - kernel locks up while booting installer
Summary: kernel locks up while booting installer
Status: Closed Not A Bug
Alias: None
Product: Base System
Classification: Unclassified
Component: kern (show other bugs)
Version: 13.0-RELEASE
Hardware: amd64 Any
: --- Affects Only Me
Assignee: freebsd-bugs (Nobody)
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-10-26 09:58 UTC by Jos Dehaes
Modified: 2021-10-27 14:03 UTC (History)
1 user (show)

See Also:


Attachments
stuck after legacy boot (934.68 KB, image/jpeg)
2021-10-26 21:18 UTC, Jos Dehaes
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jos Dehaes 2021-10-26 09:58:52 UTC
I'm trying to install FreeBSD on a free partition in my desktop system with following hardware:

ASUS prime B560-PLUS
i5 11600
radeon rx 460
Samsung 980 pro NVMe drive (Linux)
Samsung 850 EVO 500 GB SATA SSD (Linux)
Samsung 850 EVO 250 GB SATA SSD
32 GB corsair DDR4-3200 RAM

System already has linux installed on the NVMe drive, and another distro (which I want to replace with FreeBSD) on the 500 GB SSD. I created an USB stick with the 13.0 dvd ISO. Bootloader shows the boot screen, but whatever option I choose (safe mode, verbose), the kernel locks up hard the moment it tries to start. Last messages are about EFI Framebuffer. The iGPU is disabled in BIOS, output is via the rx460.

Also created forum post (and was suggested to create bug here):
https://forums.freebsd.org/threads/kernel-locks-up-while-booting-installer.82583/#post-538613
Comment 1 Jos Dehaes 2021-10-26 21:15:33 UTC
Tried legacy boot too, and then it gets further but still locks up.
Comment 2 Jos Dehaes 2021-10-26 21:18:00 UTC
Created attachment 229049 [details]
stuck after legacy boot
Comment 3 Graham Perrin 2021-10-27 06:28:29 UTC
(In reply to Jos Dehaes from comment #0)

> … Last messages are about EFI Framebuffer. …

Title of bug 255073: 

>> boot (UEFI): loader: copy_staging: no progress beyond 
>> EFI framebuffer information
Comment 4 Jos Dehaes 2021-10-27 06:59:50 UTC
With legacy boot, it does not get stuck after framebuffer, but then gets stuck later (see screenshot). I tried with latest 13-STABLE and exact same with legacy boot. When trying UEFI boot with that version, screen corruption ensues, but it seems kernel boots, but gets stuck also later. 

So there's another issue also on my system.
Comment 5 Jos Dehaes 2021-10-27 14:02:36 UTC
The other issue was ASUS BIOS. Updated to latest version and now fine. This can be closed.