Bug 259477 - www/yarn-node14: Account for NODE16
Summary: www/yarn-node14: Account for NODE16
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Luca Pizzamiglio
URL:
Keywords:
Depends on: 259476
Blocks:
  Show dependency treegraph
 
Reported: 2021-10-27 08:45 UTC by Jose Luis Duran
Modified: 2021-10-29 06:38 UTC (History)
1 user (show)

See Also:
bugzilla: maintainer-feedback? (pizzamig)


Attachments
Account for NODE16 (556 bytes, patch)
2021-10-27 08:45 UTC, Jose Luis Duran
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Jose Luis Duran 2021-10-27 08:45:43 UTC
Created attachment 229063 [details]
Account for NODE16

Node 16 has entered LTS. Account for a new -node16 slave port.
Comment 1 commit-hook freebsd_committer 2021-10-29 06:34:01 UTC
A commit in branch main references this bug:

URL: https://cgit.FreeBSD.org/ports/commit/?id=d2948b522a724f188d430654d61a0fe38652090b

commit d2948b522a724f188d430654d61a0fe38652090b
Author:     Jose Luis Duran <jlduran@gmail.com>
AuthorDate: 2021-10-28 04:11:15 +0000
Commit:     Matthias Fechner <mfechner@FreeBSD.org>
CommitDate: 2021-10-29 06:32:52 +0000

    www/yarn: make yarn-node16 available

    Currently many node packages do not support node 17 which is
    used for www/node.
    This for example fixes the usage of www/gitlab-ce which cannot
    run the upgrade step if node 17 is used.

    PR:             259475
    PR:             259476
    PR:             259477
    Approved by:    pizzamig (maintainer)

 www/Makefile                   |  1 +
 www/yarn-node14/Makefile       |  2 +-
 www/yarn-node16/Makefile (new) | 12 ++++++++++++
 www/yarn/Makefile              |  7 +++++--
 4 files changed, 19 insertions(+), 3 deletions(-)
Comment 2 Matthias Fechner freebsd_committer 2021-10-29 06:38:45 UTC
Commited, thanks.