Bug 259487 - net/samba412: Fails to configure: ERROR: Python module pytdb of version 1.4.3 not found
Summary: net/samba412: Fails to configure: ERROR: Python module pytdb of version 1.4.3...
Status: Closed Works As Intended
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: amd64 Any
: --- Affects Only Me
Assignee: Timur I. Bakeyev
URL:
Keywords: needs-qa
Depends on:
Blocks:
 
Reported: 2021-10-27 19:13 UTC by andy
Modified: 2021-10-29 01:56 UTC (History)
1 user (show)

See Also:
bugzilla: maintainer-feedback? (timur)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description andy 2021-10-27 19:13:56 UTC
FreeBSD Free_BSD_13 13.0-STABLE FreeBSD 13.0-STABLE #25 stable/13-n247809-010e3bc7727: Sun Oct 24 11:00:00 EDT 2021     root@Free_BSD_13:/usr/obj/usr/src/amd64.amd64/sys/MYKERNEL  amd64 1300519

Checking for 'zlib'                                                               : yes 
Checking for library z                                                            : yes 
Checking for inflateInit2 in z                                                    : not found 
Checking for longjmp                                                              : ok 
Checking for siglongjmp                                                           : ok 
Checking for system cmocka (>=1.1.3)                                              : yes 
Checking for system popt                                                          : yes 
Checking for header popt.h                                                        : yes 
Checking for library popt                                                         : yes 
Checking for poptGetContext in popt                                               : ok 
Checking compiler accepts -Wp,-E,-lang-asm                                        : no 
Checking compiler accepts -xassembler-with-cpp                                    : yes 
Compiling with Intel AES instructions
Checking linker accepts -Wl,-z,noexecstack                                        : yes 
Checking for system tdb (>=1.4.3)                                                 : yes 
ERROR: Python module pytdb of version 1.4.3 not found, and bundling disabled
===>  Script "configure" failed unexpectedly.
Comment 1 Daniel Engberg freebsd_committer 2021-10-28 06:59:10 UTC
The only obvious reason I see that this would fail is if you have NO_PYTHON defined

https://cgit.freebsd.org/ports/tree/databases/tdb/Makefile#n56

As this seems to be a build without Poudriere have you tried running make clean clean-depends ?
Comment 2 Timur I. Bakeyev freebsd_committer 2021-10-28 23:49:03 UTC
That feels like exact case from:

20200113:
  AFFECTS: users of python and net/samba410, devel/talloc, devel/tevent, databases/tdb, databases/ldb*
  AUTHOR: timur@FreeBSD.org

  In the entry 20191216 for the Python update the filtering constrains
  are too limiting and omit the Samba supplementary libraries, which do
  have Python bindings to the default Python 3.x version. With the update
  of the default Python3 version you also need to rebuild all the
  supplementary Samba libraries and samba410 itself.

  For portmaster users it would be enough to run:

  # portmaster devel/talloc devel/tevent databases/tdb databases/ldb15 net/samba410
Comment 3 andy 2021-10-29 01:56:28 UTC
I use portupgrade, the following fixed it for me:

portupgrade -vf devel/talloc devel/tevent databases/tdb databases/ldb15 net/samba412

Samba builds successfully now.  Thanks for the suggestion, closing the ticket.

--->  Listing the results (+:done / -:ignored / *:skipped / !:failed)
	+ databases/tdb (tdb-1.4.3,1 -> tdb-1.4.3,1)
	+ devel/talloc (talloc-2.3.1 -> talloc-2.3.1)
	+ devel/tevent (tevent-0.10.2_1 -> tevent-0.10.2_1)
	+ net/samba412 (samba412-4.12.15_1 -> samba412-4.12.15_2)
--->  Packages processed: 4 done, 0 ignored, 0 skipped and 0 failed