Bug 259488 - deskutils/gucharmap: Fails to build: ModuleNotFoundError: No module named 'libxml2'
Summary: deskutils/gucharmap: Fails to build: ModuleNotFoundError: No module named 'li...
Status: Closed Not A Bug
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: amd64 Any
: --- Affects Only Me
Assignee: freebsd-gnome (Nobody)
URL:
Keywords: needs-qa
Depends on:
Blocks:
 
Reported: 2021-10-27 19:20 UTC by andy
Modified: 2021-10-28 14:51 UTC (History)
0 users

See Also:
bugzilla: maintainer-feedback? (gnome)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description andy 2021-10-27 19:20:06 UTC
FreeBSD Free_BSD_13 13.0-STABLE FreeBSD 13.0-STABLE #25 stable/13-n247809-010e3bc7727: Sun Oct 24 11:00:00 EDT 2021     root@Free_BSD_13:/usr/obj/usr/src/amd64.amd64/sys/MYKERNEL  amd64 1300519


Installing /usr/ports/deskutils/gucharmap/work/gucharmap-cdbc989f552833ea4ac0f8fefd095ebf6d61333e/_build/help/bg/index.docbook to /usr/ports/deskutils/gucharmap/work/stage/usr/local/share/help/bg/gucharmap/index.docbook

--- stderr ---
Traceback (most recent call last):
  File "/usr/local/bin/itstool", line 27, in <module>
    import libxml2
ModuleNotFoundError: No module named 'libxml2'
Traceback (most recent call last):
  File "/usr/local/bin/itstool", line 27, in <module>
    import libxml2
ModuleNotFoundError: No module named 'libxml2'
Traceback (most recent call last):
  File "/usr/local/bin/itstool", line 27, in <module>
    import libxml2
ModuleNotFoundError: No module named 'libxml2'
Traceback (most recent call last):
  File "/usr/local/bin/itstool", line 27, in <module>
    import libxml2
ModuleNotFoundError: No module named 'libxml2'
Traceback (most recent call last):
  File "/usr/local/bin/itstool", line 27, in <module>
    import libxml2
ModuleNotFoundError: No module named 'libxml2'
Traceback (most recent call last):
  File "/usr/local/bin/itstool", line 27, in <module>
    import libxml2
ModuleNotFoundError: No module named 'libxml2'
Traceback (most recent call last):
  File "/usr/local/bin/itstool", line 27, in <module>
    import libxml2
ModuleNotFoundError: No module named 'libxml2'
Traceback (most recent call last):
  File "/usr/local/bin/itstool", line 27, in <module>
    import libxml2
ModuleNotFoundError: No module named 'libxml2'
Traceback (most recent call last):
  File "/usr/local/bin/itstool", line 27, in <module>
    import libxml2
ModuleNotFoundError: No module named 'libxml2'
Traceback (most recent call last):
  File "/usr/local/bin/itstool", line 27, in <module>
    import libxml2
ModuleNotFoundError: No module named 'libxml2'
Traceback (most recent call last):
  File "/usr/local/bin/itstool", line 27, in <module>
    import libxml2
ModuleNotFoundError: No module named 'libxml2'
Traceback (most recent call last):
  File "/usr/local/bin/itstool", line 27, in <module>
    import libxml2
ModuleNotFoundError: No module named 'libxml2'
Traceback (most recent call last):
  File "/usr/local/bin/itstool", line 27, in <module>
    import libxml2
ModuleNotFoundError: No module named 'libxml2'
Traceback (most recent call last):
  File "/usr/local/bin/itstool", line 27, in <module>
    import libxml2
ModuleNotFoundError: No module named 'libxml2'
Traceback (most recent call last):
  File "/usr/local/bin/itstool", line 27, in <module>
    import libxml2
ModuleNotFoundError: No module named 'libxml2'
Traceback (most recent call last):
  File "/usr/local/bin/itstool", line 27, in <module>
    import libxml2
ModuleNotFoundError: No module named 'libxml2'
Traceback (most recent call last):
  File "/usr/local/bin/itstool", line 27, in <module>
    import libxml2
ModuleNotFoundError: No module named 'libxml2'
Traceback (most recent call last):
  File "/usr/local/bin/itstool", line 27, in <module>
    import libxml2
ModuleNotFoundError: No module named 'libxml2'
Traceback (most recent call last):
  File "/usr/local/bin/itstool", line 27, in <module>
    import libxml2
ModuleNotFoundError: No module named 'libxml2'
Traceback (most recent call last):
  File "/usr/local/bin/itstool", line 27, in <module>
    import libxml2
ModuleNotFoundError: No module named 'libxml2'
Traceback (most recent call last):
  File "/usr/local/bin/itstool", line 27, in <module>
    import libxml2
ModuleNotFoundError: No module named 'libxml2'
Traceback (most recent call last):
  File "/usr/local/bin/itstool", line 27, in <module>
    import libxml2
ModuleNotFoundError: No module named 'libxml2'
Traceback (most recent call last):
  File "/usr/local/bin/meson", line 33, in <module>
    sys.exit(load_entry_point('meson==0.59.2', 'console_scripts', 'meson')())
  File "/usr/local/lib/python3.8/site-packages/mesonbuild/mesonmain.py", line 326, in main
    return run(sys.argv[1:], launcher)
  File "/usr/local/lib/python3.8/site-packages/mesonbuild/mesonmain.py", line 314, in run
    return run_script_command(args[1], args[2:])
  File "/usr/local/lib/python3.8/site-packages/mesonbuild/mesonmain.py", line 262, in run_script_command
    return module.run(script_args)
  File "/usr/local/lib/python3.8/site-packages/mesonbuild/scripts/yelphelper.py", line 131, in run
    install_help(src_subdir, build_subdir, sources, media, langs, install_dir,
  File "/usr/local/lib/python3.8/site-packages/mesonbuild/scripts/yelphelper.py", line 72, in install_help
    shutil.copy2(infile, outfile)
  File "/usr/local/lib/python3.8/shutil.py", line 435, in copy2
    copyfile(src, dst, follow_symlinks=follow_symlinks)
  File "/usr/local/lib/python3.8/shutil.py", line 264, in copyfile
    with open(src, 'rb') as fsrc, open(dst, 'wb') as fdst:
FileNotFoundError: [Errno 2] No such file or directory: '/usr/ports/deskutils/gucharmap/work/gucharmap-cdbc989f552833ea4ac0f8fefd095ebf6d61333e/_build/help/bg/index.docbook'

FAILED: install script '/usr/local/bin/meson --internal yelphelper install --subdir=help --id=gucharmap --installdir=share/help --sources=index.docbook@@legal.xml --symlinks=true --media=figures/gucharmap_window.png' exit code 1, stopped
FAILED: meson-install 
/usr/local/bin/meson install --no-rebuild
ninja: build stopped: subcommand failed.
*** Error code 1

Stop.
make[1]: stopped in /usr/ports/deskutils/gucharmap
*** Error code 1
Comment 1 andy 2021-10-28 14:49:32 UTC
The problem was fixed by installing:
itstool-2.0.6       Make XML documents translatable through po files

Not sure why it was not picked up as a dependency.  Closing the ticket.