Bug 259489 - www/node: Fails to package: include/node/openssl/rand_drbg.h:No such file or directory
Summary: www/node: Fails to package: include/node/openssl/rand_drbg.h:No such file or ...
Status: Closed DUPLICATE of bug 259377
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: amd64 Any
: --- Affects Only Me
Assignee: Bradley T. Hughes
URL:
Keywords: needs-qa
Depends on:
Blocks:
 
Reported: 2021-10-27 19:36 UTC by andy
Modified: 2021-10-28 21:15 UTC (History)
1 user (show)

See Also:
bugzilla: maintainer-feedback? (bhughes)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description andy 2021-10-27 19:36:08 UTC
FreeBSD Free_BSD_13 13.0-STABLE FreeBSD 13.0-STABLE #25 stable/13-n247809-010e3bc7727: Sun Oct 24 11:00:00 EDT 2021     root@Free_BSD_13:/usr/obj/usr/src/amd64.amd64/sys/MYKERNEL  amd64 1300519




installing /usr/ports/www/node/work/stage/usr/local/include/node/openssl/archs/solaris64-x86_64-gcc/no-asm/providers/common/include/prov/der_dsa.h
installing /usr/ports/www/node/work/stage/usr/local/include/node/openssl/archs/solaris64-x86_64-gcc/no-asm/providers/common/include/prov/der_ec.h
installing /usr/ports/www/node/work/stage/usr/local/include/node/openssl/archs/solaris64-x86_64-gcc/no-asm/providers/common/include/prov/der_ecx.h
installing /usr/ports/www/node/work/stage/usr/local/include/node/openssl/archs/solaris64-x86_64-gcc/no-asm/providers/common/include/prov/der_rsa.h
installing /usr/ports/www/node/work/stage/usr/local/include/node/openssl/archs/solaris64-x86_64-gcc/no-asm/providers/common/include/prov/der_sm2.h
installing /usr/ports/www/node/work/stage/usr/local/include/node/openssl/archs/solaris64-x86_64-gcc/no-asm/providers/common/include/prov/der_wrap.h
gmake[4]: Leaving directory '/usr/ports/www/node/work/node-v17.0.0'
/usr/bin/strip /usr/ports/www/node/work/stage/usr/local/bin/node
====> Compressing man pages (compress-man)
===>  Installing for node-17.0.0
===>  Checking if node is already installed
===>   Registering installation for node-17.0.0 as automatic
pkg-static: Unable to access file /usr/ports/www/node/work/stage/usr/local/include/node/openssl/rand_drbg.h:No such file or directory
*** Error code 1

Stop.
make[3]: stopped in /usr/ports/www/node
Comment 1 John Kennedy 2021-10-28 00:19:21 UTC
See Bug 259377 - www/node: Fails to package with BUNDLED_SSL=ON: pkg-static: Unable to access file ... node/openssl/rand_drbg.h:No such file or directory

Your ticket might duplicate that one.
Comment 2 andy 2021-10-28 01:40:00 UTC
Running make config and unchecking BUNDLED_SSL=ON, fixed the problem for me.  The ticket can be closed unless you want to leave it open for tracking purposes.
Comment 3 Bradley T. Hughes freebsd_committer 2021-10-28 21:15:58 UTC

*** This bug has been marked as a duplicate of bug 259377 ***