Bug 259963 - ports-mgmt/octopkg consider not using -f -y (force) by default
Summary: ports-mgmt/octopkg consider not using -f -y (force) by default
Status: Closed Works As Intended
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: freebsd-ports-bugs (Nobody)
URL: https://github.com/aarnt/octopkg/issu...
Keywords:
Depends on:
Blocks:
 
Reported: 2021-11-21 14:10 UTC by Graham Perrin
Modified: 2021-11-24 21:54 UTC (History)
1 user (show)

See Also:


Attachments
Screenshot: -f -y (32.75 KB, image/png)
2021-11-21 14:10 UTC, Graham Perrin
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Graham Perrin 2021-11-21 14:10:50 UTC
Created attachment 229634 [details]
Screenshot: -f -y

Can there be a preference to not force things by default? 

In some cases, removals – for which there's no forewarning – might be troublesome. 

<https://github.com/aarnt/octopkg/issues/3#issuecomment-183935274> it's possible to cancel an in-progress transaction, but avoidance will be preferable. 

Thanks
Comment 1 Fernando Apesteguía freebsd_committer 2021-11-24 07:49:19 UTC
(In reply to Graham Perrin from comment #0)
Hi Graham,

Thanks for the PR. Wouldn't this be something to be reported upstream instead?
Comment 2 Graham Perrin 2021-11-24 21:37:58 UTC
(In reply to Fernando Apesteguía from comment #1)

Ah, I assumed that use of -f was specific to pkg i.e. FreeBSD.
Comment 3 Graham Perrin 2021-11-24 21:54:28 UTC
(I thought that my first encounter of OctoPkg was on a Linux-based system, and that this behaviour was specific to a port from Linux to FreeBSD. In retrospect, the first encounter was probably _Octopi_, hence my confusion. Sorry.)

Works as intended by upstream. 

Await the outcome of <https://github.com/aarnt/octopkg/issues/14>.