Bug 259976 - emulators/wine-devel: Regression from i386-wine-devel
Summary: emulators/wine-devel: Regression from i386-wine-devel
Status: New
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: freebsd-ports-bugs (Nobody)
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-11-21 19:17 UTC by Dwayne MacKinnon
Modified: 2021-11-25 14:45 UTC (History)
4 users (show)

See Also:
bugzilla: maintainer-feedback? (damjan.jov)


Attachments
Error output from wine (3.08 KB, text/plain)
2021-11-21 19:17 UTC, Dwayne MacKinnon
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Dwayne MacKinnon 2021-11-21 19:17:39 UTC
Created attachment 229643 [details]
Error output from wine

I am on FreeBSD-13.0-RELEASE-p4, running wine-devel-6.21_1,1 . I run Kobo's desktop software under wine. (https://www.kobo.com/us/en/p/desktop)

The software works fine under i386-wine-devel (I kept a package of it for safety's sake after the recent ports removal.) When I try it under wine-devel (with 32 bit wine-devel & mesa-dri installed in ~/.i386-wine-pkg as directed) I get a bunch of error messages. The relevant one appears to be this:

wineserver: file_set_error() can't map error: Cannot allocate memory
Comment 1 Alexander Vereeken 2021-11-24 15:08:42 UTC
Please be aware that wine-devel is not always guaranteed to run well here, the old i386 wine-devel version you still have is much older than the current one so its could be a regression for example.

Unfortunately I couldn't test it myself because the latest wine-devel version on i386 failed to build.

I was successful in getting the program to run without tweaks with emulators/wine.
Comment 2 Alex S 2021-11-25 14:45:58 UTC
Does `env WINE_NO_WOW64=1 ...` help?