Bug 260063 - comms/wsjtz: update to 2.5.0-1.10
Summary: comms/wsjtz: update to 2.5.0-1.10
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Jose Alonso Cardenas Marquez
URL:
Keywords:
: 260064 (view as bug list)
Depends on:
Blocks:
 
Reported: 2021-11-26 12:11 UTC by lu9dce
Modified: 2021-12-22 17:58 UTC (History)
1 user (show)

See Also:
bugzilla: maintainer-feedback? (acm)


Attachments
Screenshot of a summary line (3.05 KB, image/png)
2021-12-01 00:38 UTC, Graham Perrin
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description lu9dce 2021-11-26 12:11:50 UTC
every so often the program stops receiving audio
it is still running but without being able to decode the signals this does not happen with the wsjtx 2.1.2 port
It can be seen in the waterfall window
Comment 1 Graham Perrin 2021-11-28 06:11:28 UTC
Please edit the summary lines of your reports; be descriptive, and distinctive. 

(From the summary lines of bug 260063 and bug 260064 it's impossible to guess the nature of the issues. And so on.)

Thank you
Comment 2 lu9dce 2021-11-29 12:48:43 UTC
(In reply to Graham Perrin from comment #1)

the error is due to the lack of update
the version of wsjtz that is in the repositories is not the stable one, the developer was improving and the current stable version with many bug fixes is wsjtz-2.5.0-1.10

== Changelog

V1.10
- Merged 2.5.0
- Added option to clear ignore list periodically
- Added total QSO counter in the status bar
- Added the ability to lock "TX even/1st" 
- Added the ability to set color of the separator line
- Minor fixes
- Added PSKReporter feed (View->PSKReporter view)
- Added configuration option to show the bearing in the RX Window
- Added configuration option to clear RX windows when band change
- Added Raw View (View->Raw View) that displays unfiltered messages
- Fix for ACLog callbook lookup
- Minor adjustments to the layout to allow for better RX window resizing
- Other minor fixes
- Added US state filtering/display (Settings->WSJT-Z->Show state for US callsigns)
- Fixed band selector colour in dark mode
- Fixed display issues in dark mode
- Merged 2.5.0 RC5
- Custom alerts will now show band and date
- UDP reply message will always force "Enable TX"
- Fixed an issue with DX fields not being cleared when re-sending RR73 to a station mulitple times
Comment 3 lu9dce 2021-11-29 12:58:25 UTC
this program as well as cqrlog are essential for
the world community of amateur radio

many amateur radios are thinking of migrating from linux
to freebsd when finding wsjtz and cqrlog in the repositories

since wsjtz is not in any linux distribution

I am very pleased to be able to have this soft in freebsd

In Argentina, the use of freebsd began to be seen in
radio clubs, which helps to spread this system
Comment 4 Graham Perrin 2021-12-01 00:38:19 UTC
Created attachment 229821 [details]
Screenshot of a summary line

(In reply to Graham Perrin from comment #1)

(In reply to lu9dce from comment #2)

Thanks, I mean, please edit the summary lines. 

The option to edit should be visible near the head of the page, at the line itself.
Comment 5 Jose Alonso Cardenas Marquez freebsd_committer 2021-12-01 04:44:00 UTC
*** Bug 260064 has been marked as a duplicate of this bug. ***
Comment 6 Jose Alonso Cardenas Marquez freebsd_committer 2021-12-01 05:56:12 UTC
Hi, could you test the following ports?

https://people.freebsd.org/~acm/ports/wsjtz/hamlib.tgz
https://people.freebsd.org/~acm/ports/wsjtz/wsjtz.tgz

You must to remove comms/hamlib and comms/wsjtz froms your ports tree and replace them. it will update hamlib to 4.x and wsjtz to 2.5.x. Take in mind you must remove hamlib and wsjtz if they have been installed in your FreeBSD previously
Comment 7 lu9dce 2021-12-01 12:03:25 UTC
(In reply to Jose Alonso Cardenas Marquez from comment #6)

How about Alonso.. thank you for your work -- today I test and inform you
Comment 8 lu9dce 2021-12-01 14:32:59 UTC
(In reply to Jose Alonso Cardenas Marquez from comment #6)

https://postimg.cc/gallery/mHGVx3B

good it went very well
I do not present errors
when taking out hamlib I delete cqrlog
but compile like this
hamlib
wsjtz
cqrlog

and I walk cqrlog with the new hamlib

I leave you the photos of the screen

I think you can apply the same patches from wsjtz to wsjtx
since the difference is only from the automatic part

with this you could already have 3 new soft
hamlib + wsjt Z/X

then it would be missing to see the topic of updating cqrlog since wsjt needs cqrlog to archive and manage the contacts made
Comment 9 lu9dce 2021-12-01 15:47:25 UTC
(In reply to Jose Alonso Cardenas Marquez from comment #6)

I do not know if you can add this information in the installer 
or if there is a wiki or something similar for me to collaborate with this information and the correct configuration

for wsjt functions you need to add this

-----------------

Added the following to /etc/devfs.rules:

add path 'cuaU[0-9]*' mode 666
add path 'dsp[0-9]\*' mode 666

Create ~.asoundrc to map OSS device names to ALSA
Comment 10 lu9dce 2021-12-22 17:58:11 UTC
it works perfectly