Bug 260122 - www/grafana7: Port fails to fetch due to github codeload change in dependency
Summary: www/grafana7: Port fails to fetch due to github codeload change in dependency
Status: New
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Robson Mantovani
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-11-29 16:59 UTC by Michael Gmelin
Modified: 2021-11-29 17:14 UTC (History)
1 user (show)

See Also:
bugzilla: maintainer-feedback? (robsonmantovani)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Michael Gmelin freebsd_committer 2021-11-29 16:59:24 UTC
Seems like this dependency changed for some reason:

===>  License APACHE20 accepted by the user
===>   grafana7-7.5.11 depends on file: /usr/local/sbin/pkg - found
=> prometheus-prometheus-6f296594a852_GH0.tar.gz doesn't seem to exist in /usr/ports/distfiles/.
=> Attempting to fetch https://codeload.github.com/prometheus/prometheus/tar.gz/6f296594a852?dummy=/prometheus-prometheus-6f296594a852_GH0.tar.gz
fetch: https://codeload.github.com/prometheus/prometheus/tar.gz/6f296594a852?dummy=/prometheus-prometheus-6f296594a852_GH0.tar.gz: size unknown
fetch: https://codeload.github.com/prometheus/prometheus/tar.gz/6f296594a852?dummy=/prometheus-prometheus-6f296594a852_GH0.tar.gz: size of remote file is not known
prometheus-prometheus-6f296594a852_GH0.tar.gz           13 MB 6577 kBps    03s
=> Fetched file size mismatch (expected 13838137, actual 13838140)
=> Trying next site
=> Attempting to fetch http://distcache.FreeBSD.org/ports-distfiles/prometheus-prometheus-6f296594a852_GH0.tar.gz
fetch: http://distcache.FreeBSD.org/ports-distfiles/prometheus-prometheus-6f296594a852_GH0.tar.gz: size mismatch: expected 13838137, actual 13838140
=> Couldn't fetch it - please try to retrieve this
=> port manually into /usr/ports/distfiles/ and try again.
*** Error code 1

Stop.

(affects both main and 2021Q4 branches)

Can't see the error on package builders yet, they probably use cached copies of the offending file.