Bug 260147 - devel/wasi-libc fails to build
Summary: devel/wasi-libc fails to build
Status: Closed Works As Intended
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: freebsd-ports-bugs (Nobody)
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-11-30 21:13 UTC by rkoberman
Modified: 2021-12-01 00:41 UTC (History)
1 user (show)

See Also:
bugzilla: maintainer-feedback? (greg)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description rkoberman 2021-11-30 21:13:34 UTC
I am unable to build devel/wasi-libc on a week old 13-STABLE system. I get the following error:
mkdir -p "/usr/ports/devel/wasi-libc/work/wasi-libc-ad5133410f66b93a2381db5b542aad5e0964db96/sysroot/lib/wasm32-wasi" && \
mv *.o "/usr/ports/devel/wasi-libc/work/wasi-libc-ad5133410f66b93a2381db5b542aad5e0964db96/sysroot/lib/wasm32-wasi"
error: unable to create target: 'No available targets are compatible with triple "wasm32-unknown-wasi"'
1 error generated.
error: unable to create target: 'No available targets are compatible with triple "wasm32-unknown-wasi"'
1 error generated.
error: unable to create target: 'No available targets are compatible with triple "wasm32-unknown-wasi"'
1 error generated.
gmake[1]: *** [Makefile:440: startup_files] Error 1
gmake[1]: Leaving directory '/usr/ports/devel/wasi-libc/work/wasi-libc-ad5133410f66b93a2381db5b542aad5e0964db96'
*** Error code 1
Comment 1 rkoberman 2021-12-01 00:41:24 UTC
Needs doc that BE_STANDARD compiler is required for the moment, but I it looks like that will shortly be fixed. No need for the ticket.