Bug 26015 - sysinstall doesn't change tty to cooked when changing root password
Summary: sysinstall doesn't change tty to cooked when changing root password
Status: Closed FIXED
Alias: None
Product: Base System
Classification: Unclassified
Component: bin (show other bugs)
Version: 4.3-BETA2
Hardware: Any Any
: Normal Affects Only Me
Assignee: jkh
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2001-03-23 01:30 UTC by leres
Modified: 2001-03-24 01:11 UTC (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description leres 2001-03-23 01:30:00 UTC
The "change root password" option does not revert the tty to cooked
before invoking /usr/bin/passwd.

How-To-Repeat: 
Install a 4.3-BETA2 beta system. When sysinstall asks if you want
to make any last minute changes, select "yes" and then try to change
the root password. Notice that the output from /usr/bin/passwd is
missing carriage returns and that you must use ^J to terminate
lines. Reboot and notice that you can't login using the password
you just entered...
Comment 1 roam freebsd_committer 2001-03-23 09:42:52 UTC
Responsible Changed
From-To: freebsd-bugs->jkh

Jordan messes with sysinstall, it would seem..
Comment 2 jkh freebsd_committer 2001-03-24 01:10:53 UTC
State Changed
From-To: open->closed

I cannot reproduce this - sysinstall does indeed revert the tty.