Bug 260269 - devel/cargo-c 0.9.5_2 fails to build with libressl 3.4.2
Summary: devel/cargo-c 0.9.5_2 fails to build with libressl 3.4.2
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Jan Beich
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-12-07 21:28 UTC by lysfjord.daniel
Modified: 2021-12-08 00:52 UTC (History)
0 users

See Also:


Attachments
poudriere build log for devel/cargo-c-0.9.5_2 (351.82 KB, text/plain)
2021-12-07 21:28 UTC, lysfjord.daniel
no flags Details
patch to accept version 3.4.x (459 bytes, patch)
2021-12-07 21:28 UTC, lysfjord.daniel
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description lysfjord.daniel 2021-12-07 21:28:10 UTC
Created attachment 229964 [details]
poudriere build log for devel/cargo-c-0.9.5_2

As summary say, explicit version checks are .. fun.
Comment 1 lysfjord.daniel 2021-12-07 21:28:52 UTC
Created attachment 229965 [details]
patch to accept version 3.4.x
Comment 2 commit-hook freebsd_committer 2021-12-08 00:00:15 UTC
A commit in branch main references this bug:

URL: https://cgit.FreeBSD.org/ports/commit/?id=ed815de7a6be1cc5e903cce4567cc34e3dc91a1e

commit ed815de7a6be1cc5e903cce4567cc34e3dc91a1e
Author:     Jan Beich <jbeich@FreeBSD.org>
AuthorDate: 2021-12-07 23:45:19 +0000
Commit:     Jan Beich <jbeich@FreeBSD.org>
CommitDate: 2021-12-07 23:57:50 +0000

    devel/cargo-c: unbreak with libressl after 5c5878b7d124

    error: failed to run custom build command for `openssl-sys v0.9.67`

    Caused by:
      process didn't exit successfully: `../target/release/build/openssl-sys-27209cbe1c4dcecb/build-script-main` (exit status: 101)

      --- stderr
      thread 'main' panicked at '

      This crate is only compatible with OpenSSL 1.0.1 through 1.1.1, or LibreSSL 2.5
      through 3.4.0, but a different version of OpenSSL was found. The build is now aborting
      due to this version mismatch.

      ', cargo-crates/openssl-sys-0.9.67/build/main.rs:279:5
      stack backtrace:
         0: std::panicking::begin_panic
         1: build_script_main::version_error
         2: build_script_main::validate_headers
         3: build_script_main::main
         4: core::ops::function::FnOnce::call_oncex

    PR:             260269
    Submitted by:   lysfjord.daniel@smokepit.net (based on)
    Obtained from:  upstream

 devel/cargo-c/files/patch-libressl (new) | 13 +++++++++++++
 1 file changed, 13 insertions(+)