Bug 260407 - emulators/wine update files/wine-wow64.sh to give more meaningful output
Summary: emulators/wine update files/wine-wow64.sh to give more meaningful output
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: Gerald Pfeifer
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-12-14 04:46 UTC by Zane C. Bowers-Hadley
Modified: 2022-05-12 00:35 UTC (History)
3 users (show)

See Also:


Attachments
git diff (1.58 KB, patch)
2021-12-15 22:06 UTC, Zane C. Bowers-Hadley
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Zane C. Bowers-Hadley 2021-12-14 04:46:57 UTC
Note the need for using ${ABI} in the pkg repo config if using poudriere.

Nothing about the requirements for this to work are really self explanatory or really something one is going to configure in general given for most the only reason to really use i386 is specifically for wine(even then there is a good chance not even then), so for your average config one is just going to be having the path used being the repo they want to pull.
Comment 1 Gerald Pfeifer freebsd_committer 2021-12-15 21:37:13 UTC
Can you proposed how wording can be improved?

Note, I merged this functionality as contributed by Alex, but cannot
really test/reproduce so need a little help.
Comment 2 Zane C. Bowers-Hadley 2021-12-15 22:03:36 UTC
The wording is what this is to improve, including giving the names of the symlinks that would need to be setup.

If you think it would help, I can make it more verbose with a example setup.

As it currently stands it is terrible as it is utterly non-usable out of the box for people using pourdriere and what is required to make it workable is non-intuitive. What Alex pointed me to is not something I would normally of come across or done, given maintaining a repo tends to be for a specific purpose(or several) so one would point that machine or group of machines to that repo directly, so ${ABI} is not something one would normally stumble across.

Wrote this up so bug reports like 259952 can be avoided in the future. :)
Comment 3 Zane C. Bowers-Hadley 2021-12-15 22:05:28 UTC
Derp!

I just realized I forgot to attach the patch with my suggestion. :P
Comment 4 Zane C. Bowers-Hadley 2021-12-15 22:06:09 UTC
Created attachment 230158 [details]
git diff

Proposed changing to the wording.
Comment 5 Alex S 2021-12-15 22:30:16 UTC
Shouldn't that be a patch for pkg32.sh?

Keep in mind those scripts constitute a compromise allowing us to actually use 64-bit Wine until either portmgr@ comes with a sane multilib solution (6 years and counting, and, no, they won't alow other people to work on it) or upstream implements some kind of 32-on-64 emulation (CodeWeavers did this with CrossOver for macOS Catalina, not sure how robust it is). I'm well aware of its limitations, but I'm not in position to do anything about it.

(I mean specifically 64-bit Wine — in the past most people simply ignored wine(-wine) in favor of i386-wine(-devel). Since Wine as an emulation project heavily depends on the users being able to report regressions, fewer eyes on the 64-bit port directly translate into lower day-to-day usability.)
Comment 6 Zane C. Bowers-Hadley 2021-12-15 23:53:21 UTC
(In reply to Alex S from comment #5)

The bit added is not in pkg32.sh as that is not the big instructing pkg32.sh to be ran.

Although it would be possible to say print a message like that upon failure of pkg from the pkg32.sh script.
Comment 7 Gerald Pfeifer freebsd_committer 2022-01-22 00:49:28 UTC
I plan on adding a 

  | fmt

at the end of the output to format this a little nicer.

Regarding *where* to issue this message - Alex and Zane, leave as is
or move per Alex' comment?
Comment 8 Gerald Pfeifer freebsd_committer 2022-02-01 07:23:50 UTC
Actually, I found what I believe is a better way. Commit coming (including
a typo fix "relavent" -> "relevant" among others)...

Thank you for reporting this and your patience, Zane!
Comment 9 commit-hook freebsd_committer 2022-02-01 07:33:18 UTC
A commit in branch main references this bug:

URL: https://cgit.FreeBSD.org/ports/commit/?id=9dc3d307de26ebb3ee31859fed8cc9dbc779dff5

commit 9dc3d307de26ebb3ee31859fed8cc9dbc779dff5
Author:     Gerald Pfeifer <gerald@FreeBSD.org>
AuthorDate: 2022-02-01 07:18:04 +0000
Commit:     Gerald Pfeifer <gerald@FreeBSD.org>
CommitDate: 2022-02-01 07:32:13 +0000

    emulators/wine: Add a note on Poudriere in the WoW case

    PR:             260407
    Reported by:    Zane C. Bowers-Hadley <vvelox@vvelox.net>

 emulators/wine/files/wine-wow64.sh | 10 ++++++++++
 1 file changed, 10 insertions(+)
Comment 10 Gerald Pfeifer freebsd_committer 2022-02-01 07:34:23 UTC
Note, I also had to introduce a definition of ABI to this script.

Zane, does what I committed like alright, or are there any changes
you suggest?
Comment 11 commit-hook freebsd_committer 2022-03-12 09:13:37 UTC
A commit in branch main references this bug:

URL: https://cgit.FreeBSD.org/ports/commit/?id=3f914243d8179e0d1606c7d00ee2eb3498d0bb62

commit 3f914243d8179e0d1606c7d00ee2eb3498d0bb62
Author:     Gerald Pfeifer <gerald@FreeBSD.org>
AuthorDate: 2022-03-12 09:10:49 +0000
Commit:     Gerald Pfeifer <gerald@FreeBSD.org>
CommitDate: 2022-03-12 09:10:49 +0000

    emulators/wine-devel: Add a note on Poudriere in the WoW case

    This forward ports commit 9dc3d307de26ebb3ee31859fed8cc9dbc779dff5
    from emulators/wine.

    PR:             260407
    Reported by:    Zane C. Bowers-Hadley <vvelox@vvelox.net>
    Approved by:    maintainer

 emulators/wine-devel/files/wine-wow64.sh | 12 +++++++++++-
 1 file changed, 11 insertions(+), 1 deletion(-)
Comment 12 Gerald Pfeifer freebsd_committer 2022-03-12 09:18:49 UTC
(In reply to Gerald Pfeifer from comment #10)
> Zane, does what I committed like alright, or are there any changes
> you suggest?

I did not hear back for more than a month, so synced with Damian and
also pushed this to emulators/wine-devel.

Thanks for the report and initial patch!
Comment 13 Alex S 2022-05-12 00:35:13 UTC
(In reply to commit-hook from comment #11)

Should suggest installing wine-devel instead, otherwise we get angry posts like this one: https://forums.freebsd.org/threads/wine-on-freebsd-13-am-i-just-wasting-my-time.85106/#post-566552.