Bug 260502 - net-im/py-matrix-synapse: update to 1.50.1
Summary: net-im/py-matrix-synapse: update to 1.50.1
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Ashish SHUKLA
URL: https://github.com/matrix-org/synapse...
Keywords:
Depends on: 261337
Blocks:
  Show dependency treegraph
 
Reported: 2021-12-17 20:19 UTC by Sascha Biberhofer
Modified: 2022-01-25 16:37 UTC (History)
2 users (show)

See Also:
ashish: maintainer-feedback? (ports)


Attachments
net-im/py-matrix-synapse: Update to 1.49.0 (2.83 KB, patch)
2021-12-17 20:19 UTC, Sascha Biberhofer
ports: maintainer-approval+
Details | Diff
Update to 1.49.2 (969 bytes, patch)
2021-12-22 08:07 UTC, Ashish SHUKLA
no flags Details | Diff
Update to 1.50.0 (1.14 KB, patch)
2022-01-18 12:01 UTC, Ashish SHUKLA
ashish: maintainer-approval?
Details | Diff
net-im/py-matrix-synapse: Update to 1.50.1 (1.99 KB, patch)
2022-01-19 16:30 UTC, Sascha Biberhofer
ports: maintainer-approval+
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Sascha Biberhofer 2021-12-17 20:19:17 UTC
The 1.49.0 update of py-matrix-synapse includes a few dependency changes, which have been reflected in the port. Most notably, running the test target now requires devel/py-mock>4.0.0, which isn't currently in ports. I've submitted an update for py-mock and will add that as a dependency for this update. I've also updated our dependency-patch to reflect the changes to upstream's requirements.

portlint: "OK" (3 Warnings, none new)
testport: OK (poudriere: 130amd64)
do-test: OK (Ran 2114 tests in 1074.319s, PASSED (skips=35, successes=2079))

The package has been running fine on my server and I have positive feedback from another user, so I think this should be ok. Feedback is of course very welcome. :)

Cheers,
Sascha
Comment 1 Sascha Biberhofer 2021-12-17 20:19:58 UTC
Created attachment 230208 [details]
net-im/py-matrix-synapse: Update to 1.49.0
Comment 2 commit-hook freebsd_committer 2021-12-18 08:07:42 UTC
A commit in branch main references this bug:

URL: https://cgit.FreeBSD.org/ports/commit/?id=757030bdb44734a22319f624842be356e26dbd8e

commit 757030bdb44734a22319f624842be356e26dbd8e
Author:     Sascha Biberhofer <ports@skyforge.at>
AuthorDate: 2021-12-18 07:24:33 +0000
Commit:     Ashish SHUKLA <ashish@FreeBSD.org>
CommitDate: 2021-12-18 08:03:58 +0000

    net-im/py-matrix-synapse: Update to 1.49.0

    PR:             260502

 net-im/py-matrix-synapse/Makefile                                   | 5 +++--
 net-im/py-matrix-synapse/distinfo                                   | 6 +++---
 .../py-matrix-synapse/files/patch-synapse_python__dependencies.py   | 6 +++---
 3 files changed, 9 insertions(+), 8 deletions(-)
Comment 3 Ashish SHUKLA freebsd_committer 2021-12-18 08:33:08 UTC
Committed the port, since port built fine.
Comment 4 Ashish SHUKLA freebsd_committer 2021-12-22 08:07:34 UTC
Created attachment 230302 [details]
Update to 1.49.2

This fixes a performance regression introduced in 1.49.0 as per the release notes[0].

I have not got to run the tests yet.


[0] https://github.com/matrix-org/synapse/releases/tag/v1.49.2
Comment 5 Sascha Biberhofer 2021-12-22 08:47:24 UTC
(In reply to Ashish SHUKLA from comment #4)

Patch applies and builds just fine, all tests pass (Ran 2114 tests in 1073.722s, PASSED (skips=35, successes=2079)) and the package hasn't burned my production instance to the ground, so everything looks fine. Let's get this merged. :)

Thanks for the patch! :D
Comment 6 commit-hook freebsd_committer 2021-12-22 10:14:23 UTC
A commit in branch main references this bug:

URL: https://cgit.FreeBSD.org/ports/commit/?id=cf0b7b7e25e0c2382d7f468bb4eabcc2d1e6265b

commit cf0b7b7e25e0c2382d7f468bb4eabcc2d1e6265b
Author:     Ashish SHUKLA <ashish@FreeBSD.org>
AuthorDate: 2021-12-22 07:27:54 +0000
Commit:     Ashish SHUKLA <ashish@FreeBSD.org>
CommitDate: 2021-12-22 10:12:10 +0000

    net-im/py-matrix-synapse: Update to 1.49.2

    PR:             260502
    Approved by:    Sascha Biberhofer <ports at skyforge dot at> (maintainer)

 net-im/py-matrix-synapse/Makefile | 2 +-
 net-im/py-matrix-synapse/distinfo | 6 +++---
 2 files changed, 4 insertions(+), 4 deletions(-)
Comment 7 Ashish SHUKLA freebsd_committer 2021-12-22 10:15:21 UTC
(In reply to Sascha Biberhofer from comment #5)

Committed, thanks!
Comment 8 Ashish SHUKLA freebsd_committer 2022-01-18 12:01:54 UTC
Created attachment 231124 [details]
Update to 1.50.0

Update to 1.50.0
Comment 9 Ashish SHUKLA freebsd_committer 2022-01-18 17:33:43 UTC
Actually, please ignore this diff. My testing was flawed :(. It now has an extra dependency, which I overlooked in my testing, and also noticed PR 261232, which I'll commit first while this port gets sorted out.

Oh, and also 1.50.1 is out.
Comment 10 Sascha Biberhofer 2022-01-19 16:30:25 UTC
Created attachment 231162 [details]
net-im/py-matrix-synapse: Update to 1.50.1

I've updated our port of net-im/py-matrix-synapse to 1.50.1. The changes include:

- Updated USES to python:3.7+ since upstream has removed python 3.6 from the supported python versions
- Removed the test dependency on py-mock in sync with upstream requirements
- Added a new dependency on devel/py-matrix-common, a new port that provides code shared by most matrix.org projects, inlcuding synapse


portlint: "OK" (3 Warnings, none new)
testport: OK (poudriere: 130amd64)
do-test: OK (Ran 2123 tests in 1113.279s, PASSED (skips=35, successes=2088))

The resulting package appears to work fine in production too, so I think this should be good to go once devel/py-matrix-common has been merged. :)

Cheers,
Sascha

PS: Perhaps we should open a new issue for the next release of synapse? Mixing different updates in a single issue is a bit confusing from my point of view.
Comment 11 Ashish SHUKLA freebsd_committer 2022-01-20 08:07:50 UTC
(In reply to Sascha Biberhofer from comment #10)

> PS: Perhaps we should open a new issue for the next release of synapse? Mixing different updates in a single issue is a bit confusing from my point of view.

Well, the py-mock PR was blocking this from being closed, which is why I end up adding new diffs to it.

And now that py-mock is not a dependency/requirement for this PR, I guess we can remove the dependency from the PR. Could you do the honours, please ?

I'll update and commit the PRs, if nothing else blows up in testing.

Thanks!
Comment 12 Sascha Biberhofer 2022-01-20 08:28:54 UTC
(In reply to Ashish SHUKLA from comment #11)
Completely forgot about the block. Removed it now, thanks! :D
Comment 13 commit-hook freebsd_committer 2022-01-20 13:45:13 UTC
A commit in branch main references this bug:

URL: https://cgit.FreeBSD.org/ports/commit/?id=c54c79c82dce9c97dc4bab972e15a6d4dd3b744a

commit c54c79c82dce9c97dc4bab972e15a6d4dd3b744a
Author:     Sascha Biberhofer <ports@skyforge.at>
AuthorDate: 2022-01-20 13:40:20 +0000
Commit:     Ashish SHUKLA <ashish@FreeBSD.org>
CommitDate: 2022-01-20 13:42:59 +0000

    net-im/py-matrix-synapse: Update to 1.150.1

    - Updated USES to python:3.7+ since upstream has removed python 3.6
      from the supported python versions
    - Removed the test dependency on py-mock in sync with upstream
      requirements
    - Added a new dependency on devel/py-matrix-common, a new port that
      provides code shared by most matrix.org projects, inlcuding synapse

    PR:             260502

 net-im/py-matrix-synapse/Makefile | 7 +++----
 net-im/py-matrix-synapse/distinfo | 6 +++---
 2 files changed, 6 insertions(+), 7 deletions(-)
Comment 14 Ashish SHUKLA freebsd_committer 2022-01-20 13:46:29 UTC
Committed, thanks!
Comment 15 commit-hook freebsd_committer 2022-01-25 16:37:39 UTC
A commit in branch 2022Q1 references this bug:

URL: https://cgit.FreeBSD.org/ports/commit/?id=a945caa88b40d692e193b61bc554eb7070e327a6

commit a945caa88b40d692e193b61bc554eb7070e327a6
Author:     Sascha Biberhofer <ports@skyforge.at>
AuthorDate: 2022-01-20 13:40:20 +0000
Commit:     Ashish SHUKLA <ashish@FreeBSD.org>
CommitDate: 2022-01-25 16:35:51 +0000

    net-im/py-matrix-synapse: Update to 1.150.1

    - Updated USES to python:3.7+ since upstream has removed python 3.6
      from the supported python versions
    - Removed the test dependency on py-mock in sync with upstream
      requirements
    - Added a new dependency on devel/py-matrix-common, a new port that
      provides code shared by most matrix.org projects, inlcuding synapse

    PR:             260502
    (cherry picked from commit c54c79c82dce9c97dc4bab972e15a6d4dd3b744a)

 net-im/py-matrix-synapse/Makefile | 7 +++----
 net-im/py-matrix-synapse/distinfo | 6 +++---
 2 files changed, 6 insertions(+), 7 deletions(-)