Bug 260780 - devel/ruby-gems: Sending a patch for updating to 3.3.3
Summary: devel/ruby-gems: Sending a patch for updating to 3.3.3
Status: Closed DUPLICATE of bug 258108
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: freebsd-ruby (Nobody)
URL:
Keywords:
Depends on: 258108 259491
Blocks:
  Show dependency treegraph
 
Reported: 2021-12-29 05:01 UTC by Sean Champ
Modified: 2022-02-20 15:43 UTC (History)
1 user (show)

See Also:
bugzilla: maintainer-feedback? (ruby)


Attachments
Patch for devel/ruby-gems update to 3.3.3 (8.50 KB, text/plain)
2021-12-29 05:01 UTC, Sean Champ
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Sean Champ 2021-12-29 05:01:50 UTC
Created attachment 230518 [details]
Patch for devel/ruby-gems update to 3.3.3

This diff provides an update to the latest version 3.3.3 for devel/ruby-gems

As well as the version update, the patch introduces a new behavior to the port build in that it will not produce the bin/gem symlink unless the build is being produced under the default ruby version. afaict this may help to prevent some pathname collisions under builds for different Ruby versions.  I'd added this with the update, after how the symbolic linking is approached e.g in lang/ruby30 

Outside of the particular idea for the symlink handling under the 'gem' cmd, this update may help to resolve some issues for resolving gemspec pathnames under bin or exec files for gems, e.g the 'irb' command

I've tested this patch under Ruby 3.0

HTH
- Sean
Comment 1 Dan Langille freebsd_committer 2022-02-20 15:41:47 UTC

*** This bug has been marked as a duplicate of bug 259491 ***
Comment 2 Dan Langille freebsd_committer 2022-02-20 15:43:04 UTC

*** This bug has been marked as a duplicate of bug 258108 ***